Unwanted camera pan when moving mouse to toolbar


#1

Hello, I am having unwanted camera panning when I try to move my mouse off of the design portion to my toolbar. I must hurry and click my mouse to get it to stop and then I have to reposition my camera angle again which gets very old very quickly. Please if anyone can tell me how to fix this it will be greatly appreciated. Thanks in advance, and if you need more info just let me know. Please and thank you!


#2

That is the infamous “pan border”. Not many people notice it ever, but it has been there forever. If more people were seriously suffering like you, it would maybe get fixed.

This happens when somehow a “mouse down” event is registered, but the following “mouse up” event is missed. Moving the mouse over the viewport edge will cause the border to receive a “drag” event (mouse move and seemingly button still pressed) and trigger the pan action.

  • A work-around is to properly click into the viewport before leaving it to make sure the mouse is in a proper state.
  • It’s not clear whose fault it is (mouse/touchpad driver, UI framework, SketchUp), but you may try to either update, reinstall or reconfigure the driver or play around in the driver settings to see if some setting is related with this unwanted side effect.
  • This has happend more often with touchpads than mice, so maybe switching the input device (or maybe a another, spare mouse) may help.

Mac- Model "Wandering" Off Screen or Jumping When Tools Clicked
#3

Awesome, thank you for the reply, I will give all of these a try and see if one happens to work for me. Again thank you very much!


#4

What is the active tool when you get this unwanted panning behavior ?

If wonder if hitting the spacebar to activate the SelectionTool might help before moving the mouse out of the modeling area ?


#5

It isn’t isolated to one particular tool and it doesn’t do it all the time, I didn’t realize the spacebar was the hotkey for the selection tool and I believe that will stop it. Normally I must click another tool real quick to get it to stop so I feel like the spacebar will be easy enough to hit when I need it, thanks for the tip.


#6

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.