Unusual behaviour


#1

Evening

So this has happened to me a couple of times now.

I’ll be completing a task in a component and all of a sudden all of the geometry will shoot off in a weird direction. The even weirder thing is - If I click undo it un-does the tasks before it and not the strange geometry distort.

Is there a fix to this - having to re-draw whenever this happens.


#2

How is your model located in relation to the SketchUp model origin?
Can you post the/an example model?


#3

I’m nice and close - learnt from my previous mistakes on that one (thanks to some lovely people on here) :slight_smile:

I’ve left the squiffy roof in the model as an example

It might take a minute to upload


#4

Hi @Gemma_Baird,

Without knowing what command was being executed it may be difficult to pinpoint the issue. Can you provide more information as to what precipitated the described event? It may also be helpful to upload the actual skp file (or files) you were working on each time.

Also please complete your user profile to include the graphics card being used in your system. You should be able to locate this information on your Windows based PC by going to: Control Panel > System and Security > System…now click the tab for “Device Manager”. The Device Manager dialog box will appear. Scroll down to “Display adapters” and expand the category if an arrow appears next to it. This will show your graphics card. Be sure that your drivers for the display adapter are current and this may resolve the issue of itself.


#5

Hello

The sketchup file is too big so there’s a dropbox link above.

This time I was trying to copy a component inside a component and place an additional copy in another location within the same component. That said it has happened when extruding and when erasing in the past - also within a component.

Graphics card wise I’m on a … and all the drivers are current (just checked)


#6

Dropbox has synced so the file is now available as above


#7

Though it is hard to say what exactly happened with the file, (the undo stack does not get saved) there are a few possibilities.

  • It can happen if you have something selected and trying to move something else, without noticing it. (Keep an eye on the entity panel)

  • If you have ‘raw’ geometry on a layer, other then Layer0, and move something that is still ‘attached’ to it. Mind You, if you explode a component, the contents inherits its parents Layer, thus resulting in having raw geometry lying around on other Layer then Layer0.

  • If you are moving something and the inferencing system is trickered by a lot of points of interest, nearby the position of the camera. Try orbiting to a more appropriate view and lock the movement.

happy sketching!


#8

That is a very big file!

It’s not obvious what you did without seeing a video (you can use licecap to record your actions). I do notice that most of your raw geometry is on a layer other than Layer 0. All raw geometry should be on Layer 0. Raw geometry means the actual lines and surfaces that comprise a group or component. It is the groups and components that should be on other layers.

If you want to copy something from inside a component to another location, the best way is to use Cmd-Copy and Cmd-Paste. If you want to paste it the the exact same location use Paste in Place.


#9

Is it a problem that its a large file ? I don’t know how I could make it any smaller, I need all of the elements within it to be present.

I purge once an hour and check for errors.

So I do use command copy and paste as you’ve said, but I’ve had this issue when extruding a face too so I don’t think its my copying method.


#10

The file size has no bearing on the problem but may affect how easily you can manipulate the model when working on it. That also depends on what computer you are using and its ability to regenerate images.

I think it most likely that you are doing something unexpected when you copy or extrude but I suggest you upload a short video of what you are doing otherwise we are all just guessing. There is nothing in your drawing that suggests it should act oddly.


#11

Thank you

Unfortunately I don’t know when it is going to happen and happens completely unexpectedly so it would be impossible to create a video


#12

If you see no pattern you may be stuffed. If you think it could be SU doing funny things, the only other option is to reinstall and see if that cures it.

Have you been using SU long? I see that you only joined the forum a few weeks ago.


#13

I’ve been using sketchup for about 3 years now - but I’ve only recently found this place, before that I was slogging through on my own.


#14

You need to read up on how to use layers, i suspect the way you are using them is causing the issue, but that’s only a guess.
Have a look here.
https://help.sketchup.com/en/article/3000122

You also need to keep on top of Face Orientation, you have quite a few reversed faces.
If you look at your model in Monochrome you should only see white faces, the Blue ones are back faces and can cause issues with rendering and 3d printing.


#15

That face orientation thing is so frustrating, when I’m drawing quickly I don’t usually fix them until the end (the render stage) because it takes up so much more time.

Is there any way to stop that happening ? I mean the reversed faces.


#16

Another way of noticing ‘correct’ use of layers is to use the ‘Color by Layer’ style.

When using boolean operations, be Xtra careful!


#17

In my experience, the only (nearly) certain way to “stop that happening” is to do two things:

  1. Create a style that shows monochrome faces AND has a higher contrast “back” face color (as contrasted to the “front” face.) I use white for the front and red for the back. Use this style for your basic modelling.
  2. #1 causes you to easily and quickly notice reversed faces. So the action item here is to change your work flow to always correct face orientation the instant it appears. Believe me, it takes far less time to correct it early than to try to correct multiple, possibly very small, reversed faces later on!

#18

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.