Model Being Corrupted by Sketchup

Running Sketchup Pro on a mac.

Was working on cleaning up some rounded edges intersecting curved surfaces when suddenly SU corrupts my model. After zooming out, it appears that some of the model points were moved to the origin. I was using the eraser tool at the time and watched it change as I was moving the mouse, possibly rotating the view. This has happened several times today. If I undo several steps, it does not undo the corruption.

I tried copying this component to a separate file to eliminate all other components. It still happened. I tried restarting SU and it still happened. What are my options to save this model?

Thanks
sensor box cover.skp (1.9 MB)

It looks to me as if you moved most but not all of the the geometry which caused distortion.

Yeah, it looks that way, but that is not what happened. The eraser tool was selected. If I could undo and recreate it I would video what happened, but it will not undo. That is another clue there is a real problem.

Are you using flex tools, it look a bit like this other issue. It has not been specifically proven but this is suspected to be an interaction of an extension and auto save acting simultaneously. Flex Tools is one suspect.

There are four edges still over at the origin. Maybe leftover from whatever caused the issue? But why is the main portion of this small part so far from the model origin? Also, there are some pretty small edges in the model. You might need to use “the Dave method” (search the forum for details) to avoid possible issues with them.

This component was part of a larger model with other components. When the problem occurred, I saved it to its own file to eliminate the possibility of the other components causing the problem. Since all components can’t be at the origin at the same time, this one was moved away to work on others.

It’s already scaled to 100x desired dimensions. With curved surfaces, I’ve found there is no scale big enough to avoid minute line segments. Most of the minute segments are created by the SU tool “Intersect faces”. If you have a process that eliminates that issue, I’m all ears.

That sounds like you may be using too many segments in the arcs of your curved surfaces. That, plus irregular alignment between the segments where curved faces meet are common sources of too-short edges. From your statement, I assume you tried scaling by 1000 or even 10000?

I don’t believe I’m using the “flex” tool. Here are the extensions I have installed:


1 Like

I also found the four edges that Steve referred to. They were a long way from the rest of the geometry but still inside component. I gather you imported this from a .stl file?

I’ve redrawn the model in SU. The one in the background is yours. Does this look like what you really want?

Yes, but those edges that were at the origin were moved there by SU WHILE I HAD THE ERASER TOOL SELECTED. This happened several times today with this model. What did I do wrong?

I don’t know. I’ve never had that happen in my models.

I’m continuing to “play” with this to isolate the problem. Reverted to a version that was did not have part of the model moved to the origin. Moved the component to the origin. Scaled up 10x again, so now 1000x. Performed “intersect faces” on the entire component to try to clean up the intersecting curved surfaces, selected the line draw tool and BAM some parts of the model were moved to the origin again. I didn’t even click to create a line yet.

Well that looks great. Wish I could get work done that quickly. Are you running on a mac and what steps did you perform to clean this up?

Did you correct the scale of the definition when you scaled up?

I started from scratch with my version above after I exploded the original component. There’s too much garbage in the component you were working with. It was easier to start over using the original as a reference and making sure I didn’t create bad geometry as I went along. Due to the nature of .stl files, they generally have a lot of bad geometry that needs fixing and I almost always prefer to model it correctly from the beginning than to repair.

I’m using a PC.

1 Like

Well I’m obviously going about things the wrong way. I’ve spent 16+ hours a day for the last month and a half learning and working in SU. With years of experience in graphics and 3D modeling, I thought I was doing pretty well. Your results indicate there is another level of SU skills that I cannot find in documentation or videos. My challenge is cleaning up the minute problems that prevent a component from being a “solid”. I use Intersect Faces, Cleanup3 and Solid Inspector2 on a regular basis. Intersect Faces tends to cause as many problems as it solves by creating “too short” line segments and creating holes in a solid. Where am I going wrong?

In general those tools should help although I didn’t use any of them in modeling this cover. There just wasn’t any need for them. Your model has a lot of problem geometry created by the triangulation that is a feature of .stl files. Even with those tools and Instersect Faces, the bad geometry will still be there. By starting over I avoided all that junk.

FWIW, I didn’t use Intersect Faces, either. I created “drills” as 3D geometry (solids) to create the countersunk holes and the cone-shape hole and then used Trim from Eneroth Solid tools to make the holes in the cover. Speedier process and it doesn’t result in a lot of stuff to clean up.

Thank you for the tips. I have been using trim from the standard built-in solid tools but will checkout the Eneroth Solid Tools. The Eneroth Upright Extruder Tools were invaluable for thread modeling I did weeks ago. I’ll try to avoid intersect faces for curved or rounded surfaces.

To summarize for others:

  1. Not sure why the model is being corrupted
  2. Create a new model based on an imported STL model rather than try to clean it up
  3. Avoid intersect faces
  4. Use the Solid Tools “Trim” function to create tapers or carve-outs in shapes

Thanks again!

I have seem similar bizarre origin-homed geometry many times. In my experience, it is sometimes caused by SketchUp’s Undo function when executed after a Validity Check operation that “fixed” the model. Here is an example that I provided to a SketchUp employee last November (along with some .SKP files in various stages of the sequence):


To be clear: The bogus origin-homed geometry is not created by Validity-Check itself. The bogus extra geometry is (sometimes) created when the Undo function is executed immediately after doing a Validity-Check that had made geometry changes. The geometry will usually be eliminated if you continue undoing more steps; it may take five to ten Undos to get the bogus geometry to be removed.

1 Like

An addition to my reply above: for me, the Validity-Check operation is triggered when doing a manual Save operation. If a Save occurs automatically (due to SketchUp’s auto-save feature) and the user does an Undo coincidentally right after a Validity-Check that modified the model, the bizarre origin-homed geometry might be created - just a guess.

1 Like

It is generally associated with Autosave (and the val check) and tends to stop when people turn autosave off.
It doesn’t seem to require the undo part specifically, but there is usually something going on when autosave kicks in and the geometry goes nuts.
This one going to the origin may be specific to Undo, the others tend to fire off in random directions.