UnSelectable / locked geometry?

I’ve been playing with lego units, and I wanted to compare the ones I made with someone else’s, so I downloaded Aaron’s little falcon from the warehouse.

Having exploded the main group, I cannot select several of the little groups at all. I can access them in outliner, and ‘’edit” their properties, but not select them in the field. Are they locked?

Can you select them?
LEGO.skp (1001.0 KB)

I’m not having any trouble selecting them on my PC. Maybe save and quit SketchUp and reopen it. Any change?



I tried that. I tried copying the file, I tried copy pasting out of the file… I tried taking the corresponding pieces out of the little millennium falcon…

I’ll try downloading the little model again

Does it work with this file?
LEGO.skp (998.1 KB)

No, it’s exactly the same. I tried the pencil in another file quickly and it selects as expected.


I downloaded your modell, opened in my iPad and I don’t have any problems selecting any of components in any combination . Perhaps try to restart your iPad…

That was one of the first things I did :wink:

1 Like

Looks like there are some strange things going on.
Double clicking in the outliner results in dataloss.
@colin might have a clue?
When importing the original from the warehouse, it gets a temp name.

So, on my iPad, no problems. On my Mac, I could select with the Select tool, but not the Lasso tool. If I double-clicked into a component, the geometry disappeared, never to be seen again.

Trying to see what is odd about it…

This happens on mine as well. I have to restart the iPad to get it back.

If you could give a vague answer to this, is there a chance you are on a more recent version of the iPad app than most people?

I am seeing the issues in not yet public versions of the desktop app and the iPad app. I will log a bug report.

@MikeTadros I created SKOR-16565 to cover this. Pretty sure it’s not an iPad specific issue. I will rally the troops so this is looked at on Monday.

@colin I am currently on the most up-to-date version possible… It would make sense to me that that’s where you’re seeing them.

One funny thing, the components that show a problem were built in a way that presumably contributed to the issue we’re now seeing. Normally it would be difficult to ask someone to describe the steps they used to make something. It’s less of a problem when that happened on live YouTube.


I will bring a new cap for the SketchUp guy to cover up.

1 Like

If that is not a deep fake I am envious.

That problem is not new for me, in the past somethimes i could select all component by ctrl+A, but couldn’t select by clicking on it… I thought it was the way the component created and forget about it… I can’t remember how i solved that, may be selecting with ctrl+A and explode i don’t know…

Some progress…

Aaron modeled the Lego pieces in meters instead of millimeters, to avoid too small geometry issues. This version of the model has gone through the 0.001 scale change to make it be life sized. If you now try to edit at that size you’re back to possible too small geometry problems.

A recent change has added a couple of new symptoms to those problems, we need to revert that change or do the change in a better way. At least we have an easy test case to show if things are good again.

Meanwhile, if you went back to the Aaron scale of working, the problems you’re seeing will go away.

1 Like

I didn’t check the model before but indeed, none of the components had their definitions scaled after scaling them down to real world dimensions.

@Danimaupin see if this version of the file plays better for you.
LEGO (1).skp (630.8 KB)