Unreal Datasmith with Sketchup 2022 and Unreal 5


I’m working on sending my Sketchup to Unreal and have just installed Unreal Datasmith for Sketchup 2022 and Unreal 5 from the Unreal website. But in my extensions manager it says that the signature information is unassigned. Is anyone else having this issue

Quite normal, ignore it. Many extensions are unsigned.

I do have some other extensions that have the same problem and I’m able to use them just fine. But when I try to export with the datasmith file it is nowhere to be found in my export or the attachment export feature.

Are you using the export button that is included in the Datasmith toolbar?

Yes. I have tried both that button and the export dropdown in File.

The datasmith export only appears in the extension toolbar as a button, it’s not under file>export or anywhere else. What happens when you push the export button on the toolbar? You should be asked where to save the file in a pop up window.

So I found my problem. I had tried it with the extension toolbar, and it only gave me the option to name the file and not select what file type, which is how I’m used to exporting things. But I found that I just needed to hit save and it worked.

Thank you all

True, no file type options exist, the datasmith extension only exports datasmith format. Did you set your file into Unreal?

Yes. I was able to get it into my Unreal.