Unable to save/upload or open projects from Trimble Connect on iPad

I am experiencing an issue with Trimble Connect on SketchUp for iPad. Specifically, I am unable to save/upload locally saved projects to Trimble Connect or open projects from Trimble Connect. Whenever I try to save a project, I receive an error message that says “Save Error - There was an error while trying to save.”

Additional Information:

  • I have a stable internet connection.
  • I tried saving and opening multiple different projects and it didn’t work with any of them.
  • Strangely, the app correctly shows all of my projects on Trimble Connect and updates any changes I make from my PC.
  • I have tried deleting and reinstalling the SketchUp app, with no success at resolving the issue.
  • I tried recreating the same steps on SketchUp for Web on my PC (connected to the same network), and it worked just fine. So the problem seems to be with the iPad app only.

Have you tried restarting the iPad?
By saving a project, you mean saving the model locally in files on the iPad or to a Project that is hosted on Trimble Connect?

Yes, I have tried restarting the iPad right after I reinstalled the app, but unfortunately that didn’t solve the issue.

By saving a project I mant saving the model locally in files on the iPad.

Models hosted on Trimble Connect need to be downloaded first on the iPad (click on the three dots)
Then, they should be in a folder named ‘On my iPad > Sketchup

Hi. Im having same issue.
Also using the iOS app on IPad Pro. Latest update. Just restarted the iPad and reinstalled the app.
I cannot interact at all with my files in the Trimble Connect tab. I can see that clicking on the tree dots beside the file is registered because the turn dark grey (from white) but nothing happen. No drop down menu or anything. Normally I’m able to work on the file directly from the Trimble Connect but now the section is unresponsive.

1 Like

Same thing for me.

Same here. Problem arrived immediately after the latest auto IOS update 16.4.1 (a).

I’m having the same issue, I cannot open already created models from Trimble connect.

I reached out to SketchUp and they told me check this forum.

I’m experiencing the same exact issue. Hopefully they address it soon

Hi, it seems that this topic wasn’t be taken care of properly, despite there are many people complaining about the same issue. My Sketchup for iPad stopped working with the same problems as described above. Files on Trimble Connect shown, but none of them are editable. The three dots, when hovering, showing “More” as usual but no popup menu when it is clicked. Troubleshoot steps made:

  • Close and reopen Sketchup for iPad app
  • Restart iPad
  • Uninstall and reinstall Sketchup for iPad app

My iPad did not even been updated to the newest iOS

Machine info: iPad Pro 12,9” - iPadOS 16.1 (20B82)
Plenty of internal storage space as well as iCloud storage

The only thing that works temporarily is to use Safari and log in to Sketchup Web and download the skp file to edit directly (locally) on iPad. However, publishing to Trimble Connect doesn’t work either.

My work is at the construction and I have to make drawing on site, I paid for the products and couldn’t use it and hopefully someone from the team is kind enough to just take a look or let us know if there is some problems and how long should we wait.

Hi. I also am experiencing this on iPhone version since latest update. Have been able to view models in Trimble Connect without issue before update. Hope it can be fixed.

It seemed that we were abandoned…? I have tried every possible cases to troubleshot this issue. However, what I have found so far:

  • Clicking on Trimble connect icon bring me list of projects created and hosted on cloud as usual
  • However, cannot edit or delete projects (clicking on three dots brings no popup menu)
  • Can create new project. However, as stated above, nothing could be done with it
  • Create new sketchup model and save, give me error as below

I hope someone from the team could take a look and at least let us know that you care… One might think what‘s the problem when I still can use Sketchup Web or desktop, but try it once - bring the laptop on your hand while the other hand hold the mouse drawing at construction site…

I’ve msg’d a couple of you but no response. Please ping me so we can test your exact configuration to see what’s going on. We only have a few of these, and there’s no immediate solution unless we can try it out. Bonus points and a beer/coffee if you’re near our office.



I’m also curious whether there’s a pattern associated with issues being isolated to a specific Trimble Connect ‘region’.

For those of you who are experiencing issues, which regions are your new/existing projects stored in?

Same problem here!

Which continent? PM me if you don’t want to share publicly… we still cannot repro this.


North America