Unable to retrieve data!

Hi,
I have very recently started to learn sketchup on sketchupweb and have a small number of files saved on my trimble connect account. This morning everything loaded up fine and I started a new file, but when I tried to rename and save it, I got a wacky graphic and “unable to retrieve data” message. The only thing I did differently was to click the suggested “install sketchup app” button on the google chrome address bar. I have signed out and back in again, uninstalled the app and any cookies added today, and restarted the browser and the pc but I am still unable to access any files. When I click Home on sketchup then ghost boxes, of the files I am expecting to load, flash up very briefly and vanish before the “Welcome to SketchUp” appears.
Please help!

Oh and my internet connection is all fine.

this is happening to me too :frowning:

Hey there, same issue on my account, what is going on with the sketchup (Trimble Connect) Server?

Same issue for me. Cant even save a new project. Guess there is a server issue

Message: We were unable to retrieve your data, please select “Retry” below to try again.

Trimble are doing site maintenance. 8.30-14.30 today. Found a link on another thread. Should be back to normal soon.

Trimble Connect was down for scheduled maintenance but the maintenance is complete. You should find your models aren’t actually gone.

Trimble Connect was down for scheduled maintenance but the maintenance is complete. You should find your models aren’t actually gone.