Unable to retrieve data

When I attempt to open a plan, I get the message, "Unable to retrieve your plan, please select “Retry” below to try again.

Other behaviours that I experience include:
When I login, Sketchup displayed a number of plan boxes (similar to the number of plans that I remember having), but then displays “Welcome to Sketchup”, Start modelling" pop-up.

Help needed please as I have lost a good few weeks work.

What browser are you using?
Try to open an incognito or private tab and sign in at www.sketchup.com

Be sure to use the email that you used when creating the files

Thanks for the tips Mike. Tried going incognito on Chrome and Firefox. Not working yet.
Double checked back to confirm which email/ID I had used and I have reconnected via the right email. No luck with that either.
I have not used my account since autumn/fall 2020, could that have anything to do with it, as I know that accounts etc. look like they have changed.

After several attempts, I tried a piece of hardware and found models.
Problem understood, if not fully solved. Thanks for the help.