Unable to install extensions - another reinstall problem (SOLVED)

After the first problem was solved (no Sketchup folder in the App Support folder) I started installing plugins but could not do it because of messages to effect that I did not have enough permissions to do so. I tried with the Extension Warehouse and the Sketchucation Plugin Store (see the attached screenshots).

Following an article by Rich O’Brien published at Sketchucation, I went to the plugins folder and gave full permission to everyone but that did not solve the problem (screenshot attached). I am still getting those messages and unable to install anything.

Have you seen this before? Do you know how to fix it?

I am running Mac OS 11.2.3 and Sketchup 22.0.353.



Screen Shot 2022-03-29 at 10.19.55


During the night I realized that I had transferred the Plugins folder from a backup from the old SSD. I moved the entire folder, not just its contents. It probably had another set of permissions that had to do with the old drive and the new installation would not recognize it.

The solution was to reinstall Sketchup from scratch and the new installation is behaving as it should.

You could have avoided this mayhem by installing your extensions fresh as is recommended by all SketchUp sages…

This is true but if you knew how many extensions I normally have installed you would think twice about it.

Besides, I have moved extensions from one version to another for 15 years without any problems. But never before just after changing a hard drive.


1 Like

It’s true, it can be done your way and some people can do it without creating problems down the line. But it is also true that a lot of people that do it this way get weird problems and errors. Some imediatly but some after a while when it is not obvious anymore that copy/pasting extensions is the culprit.
The sages have a solid reason to advice against this practice…

There is a problem that can come up if your hardware has changed, though I think for Mac it would need to be a motherboard change, not just a drive change. Even so, Profile Builder looked like it might have a problem for you, so I took care of that, just in case.