Unable to close a face on cabinet side

I have created a component for a cabinet (see attached) but I cant seem to close the side face. I’ve retraced all the lines but still cant fix it. Any hep would be much appreciated. SKP file of the component attachedCabinetSide.skp (216.8 KB)

You have the face hidden. It’s there. You just can’t see it. Turn on Hidden Geometry and you’ll see it. Open the component for editing, right click on it and choose Unhide.

Hi Steve, I found it useful to go into window/preferences/short cuts and create a short cut for hidden geometry. I use G and Z and X for undo and redo.

Great, thanks Dave. It’s my first time using Sketchup and already impressed by the forum!

Another tip, disable length snapping for more precise measurements. Also model at the finest precision for the measurements selected, ie 1/64 or 4 or 5 decimal points.