Unable to change tag style

After having played around with the free version for a few months I just started a subscription fot Sketchup Shop to be able to access some features not available in the free version. One such feature was to be able to apply different line styles and colors to tags. After a few attempts it worked with the one tag. For some reason the change was also applied to another tag. But now I’m stuck, unable to change either one of the two, neither colors nor line styles. The indication of chosen line style next to the tag changes but the items tagged stay unchanged.

Have tried re-launching the web browser and the entire computer (Mac Mini with M1 architecture). Any ideas?

How about sharing the .skp file so we can see what you are working with and get you sorted out?

Surprisingly quick response! Please find the .skp file attached (I think, Im all new to this).
Hagvagen FP9-2.skp (1.3 MB)

I’ve been sitting here waiting for you to show up. Started wondering when you would ask your question. :crazy_face: :crazy_face:

One problem I see immediately is incorrect tag usage. I have the geometry of the floor plan selected and Entity Info shows “Multiple” when it should say “Untagged”. That is just one example. This will create problems for you when you are trying to use tag colors and dashes. ALL edges and faces should be created and left untagged. Only groups and components should get tags.

In order to show the tag colors you need to enable that by clicking the button at the top of the Tags panel.

If you want edges to get the tag color, also turn on By Material in the Edge settings for the style. Here it’s shown as All Same and set to black.
Screenshot - 5_18_2021 , 12_03_33 PM

1 Like

More:

Here I’ve opened the file in the desktop version so I could use some extensions. First I fixed the incorrect tag usage.
Screenshot - 5_18_2021 , 12_08_43 PM

Then I purged unused stuff from the model which reduced the file size by more than 74%.
Screenshot - 5_18_2021 , 12_08_56 PM

If you want to be able to show the plan to some sort of scale, you need to set the Camera to Parallel Projection. You have Perspective chosen for the scene as evidenced by the visible blue axis in the Top view.

You also have quite a lot of loose geometry which should be collected into groups or components.

Here’s the file with the changes.
Hagvagen FP9-2 dr.skp (338.3 KB)

Many thanks Dave! It is obvious that intuition sometimes leads you down a bad path. I don’t know how the default tag became “Multiple” instead of “Untagged”. I noticed at one point after reading something about untagged trying to find an answer to some problem I had but figured it was something that had changed with recent versions just like layers was changed to tags. Anyway, I very grateful for all your help.

Greetings,
Anders

‘Multiple’ displayed in Entity Info means that the different entities in the selection have different tags.

Typically this happens in a couple of ways. One is when users try to use tags to separate geometry (edges and faces) like they would separate things with layers in AutoCAD or Photoshop. Tags don’t work that way. You need to use groups and components to provide the separation. The other way that this sort of thing can happen is by exploding groups and/or components that have had tags assigned to them. The contents of the group or component inherit the tag assignment. Best practice if you have to explode objects is to immediately correct the tag assignment to Untagged in Entity Info. Immediately after exploding components and groups the contents will still be selected.

Okej, so I’ve imported your version of the file and the problem remains. I still can’t change tag style (although I could at some point since lines of two of the tags are no longer solid). Are you saying that the file is beyond repair and my best bet is to do the sketch all over paying more attention to creating groups and components along the way?

I never said that or implied it.

Which tag(s) are you trying to change and what are you trying to change about them?

I would say that your model still needs some fixing. Lots of loose geometry that needs to be wrapped up in groups or components. Certainly for future projects it would make sense to use correct modeling workflow to avoid creating problems for yourself.

FWIW, if this is the sort of thing you do for your work, I would highly recommend that you consider upgrading to SketchUp Pro so you also have LayOut for creating the output you need after the model is complete.

What I’m trying to change is the tag for the “Current Floorplan” the outline of which I’d like to have a dash-dot pattern. Then want to get the outline of the “Foundation” back to solid lines. So perhaps I should remove the tag from what I call the “Foundation”? But in that case how do I make only the outline of the old floor plan/foundation with a dashed line.

That tag shows as having the dash-dot pattern already. Most of it is hard to see because it is masked by the Foundation component.

The Foundation tag already shows as set to solid lines, too.

Removing the tag from the component called Foundation won’t change anything with as far as the appearance of the Current Floorplan component is concerned. If you are trying to see the Current Floorplan and the Foundation, you should move the Current Floorplan component up in the Z direction (toward the camera) so it is above the foundation. Remember that SketchUp is a 3D modeling application. You need to work in it as such.

Here I’ve moved the Current Floorplan component up above the rest of the model. I turned on Color by Tag and set the colors to make the dash-dot lines for that component be more prominent. I also turned on Profiles in the style and set them to 2 to help make the dashed lines more apparent.

Thanks so far but my problem is that the sketch does not look the way it does in your screenshots when I open it in Sketchup Shop on my computer. Although the line style is shown in the Tags panel as solid for the Foundation and dashed with intermediate dots for the Current floor plan that’s not how they appear in the sketch, even when I open the one that you have worked on. What’s going on?

Anders,

I only just got a notification that you replied to this thread.

Did you get this problem sorted out? What browser are you using? Can you show a screen shot of the Tags panel?