Unable to add classic license

Hi,

When trying to add a classic education license I always get the message “Oops… SketchUp Pro is unable to connect to the network license server”

I am replacing an installation of SketchUp 2019 which used to work fine with a new installation of SketchUp Pro 2020 and a new license sent by my reseller.

I tried:

  • Deinstall and reinstall with user and admin account
  • Disable virus protection and firewall
  • update Win 10
  • Download the installer again
  • Wipe program folder, including everything in *C:\ProgramData\SketchUp*
  • Delete registry entries
  • enter port entries in firewall manually
  • everything described here
  • waiting some days and do everything again

The installation went smoothly on my machine at home.

Now I ran out of ideas and need some help what else could solve the problem.

If you are having problems at the office site, but the otherwise identical process worked at home, I wonder if your IT department or equivalent has blocked the port number that Sketchup uses to ‘call home’ to authenticate the licence?

I don’t remember what port it is, but I think I saw on this forum a good while ago that it was not the simple port 80 or 443 for HTTP or HTTPS which would usually be allowed through.

For network licenses, add port 5053 and 50530 as well

One challenge is how to test whether a port is blocked. You might think that ping should work, but it doesn’t. The solution is telnet.

In the Windows ‘type here to search’ field, type telnet. If telnet itself shows up, replace telnet with com or cmd, to run the command prompt. If not, choose the entry that says Turn Windows features on or off. In that list you will see telnet, click the checkbox, to enable telnet.

Once telnet is enabled, and you’re at the command prompt, type this line:

telnet license1.sketchup.com 80

If port 5053 is available, the window contents will clear. You can tap ctrl-c a couple of times to exit that. If the attempt to connect fails, or gets stuck, that port is blocked.

Repeat the test for 8080, 8888, 443, 5053, and 50530.

Hi,

Thank you for all your help!

I checked now the ports. Port 80, 5053 and 50530 are open. 8080, 8888 and 443 are not.

The admin will not open Ports for me. Is there another way I can add my license?

If it’s a computer that has WiFi you could connect it to your phone as a hotspot, just long enough for the license to activate.