Turn object solid (hollow)

I am trying to grab a STL off of thingiverse, cap the bottom off so it is a solid and delete all the stuff inside the skin. The problem that I see is that it is has some very small parts and maybe Sketchup doesn’t like it. When I try a cleanup or solid inspector, it will delete some of the smallest objects off of the drawing. I think those parts have no skin. Although, Cura and even 3D Builder have no issues with the raw STL.
Here is the file:
https://www.thingiverse.com/download:2709923
Importing this file takes almost a minute and the cleaning geometry stage drags the whole event to a little over 3 minutes. It’s such a pain to select and work with these files.

First thing I would do is clean up the excess, unneeded faces with CleanUp3. Then run Solid Inspector2 and fix the problems it lists.

Looking at this model a little closer, I think you’d be better off to model it from scratch instead of trying to use that thing. It’s way over modeled and will cause SketchUp to slow down considerably.

1 Like

That’s the route I have gone, even scaled it to 1000 times its size… Cleanup3 will delete the little planets on the end… so will solid inspector. I think I’m going to call it quits on this project. I’ve tried so many things in the past 2 days.
But on a side note, how do you get the view you have there? I see the xray, but I dont see how you hide the geometric lines.

I didn’t lose any planets when I ran CleanUp. I imported the STL with Units set to Meters in Options. I let it soften the edges as it was going. Note the last setting in the UI.

1 Like

It’s pretty easy to re-model using the previous STL as reference. I didn’t have time to trim out the bottom or run Solid Inspector but if you want to keep going, try this vs forcing a cleanup of that other file.
32%20PM
Planets.skp (3.8 MB)