Any help with making this solid

Need help with this not turning solid after cleanup and solid inspector 2. I downloaded a stl and worked it until I got something I like but I tried blowing the model up by ten times several times. Tight now there is the giant model and the original at the origin. Thanks

New s10.skp (3.1 MB)
Here is model

I looked at your model. You apparently had a component nested inside another identical component. When I tried to run Solid Inspector and CleanUp 3, I got an error message. So I exploded the model and remade it as a component. CleanUp3 got rid of some junk. But Solid Inspector identified some problems that it can’t fix automatically. It also looks as if you stitched the faces together manually. You should soften or erase all those extraneous lines.

This model is a bit of a tessellated mess sorry to say. There are loads of tiny faces and edges as a likely result of the STL import that are not trivial to resolve. All the triangulation you see is actually tiny variances in the surfaces, these surfaces are NOT coplanar, many are off by .000 MM. If all the lines were actually triangulation on one single coplanar surface as sometimes happens with file imports it would be possible to manually erase the lines or use cleanup to merge coplanar faces. Hiding the lines or softening them will make them appear to be gone in SU but if your end goal is to print this then simply hiding the problem won’t help.

Very little is flat or straight in this model.

2 Likes

Solid Inspector says that even in the enlarged model, you have 6 Short Edges.

Here’s one of them, top right corner, highlighted red.
image

Just running CleanUp3. It’s taking a long time to run. Had to Force Quit, then the plugin crashed.

Will try again.

Didn’t wait long enough, and I was running it in an older version of SU.

Tried again in SU2020, and it ran to completion:
Cleanup Statistics:

Edges Reduced: 10
Faces Reduced: 0
Purged Components: 0
Purged Layers: 0
Purged Materials: 1
Purged Styles: 0
Skipped Locked Definitions: 0
Total Elapsed Time: 3m 7s

Then tried Solid Inspector again. It now says Everything is shiny

But SU doesn’t see it as a solid component. Hmmm.

Best i think I can do is to save it back to v2017 for you, with short edges fixed. It will probably print ok, if Solid Inspector thinks it is a solid even if SU doesn’t. Try running it through your 3D printer’s slicer
New s10 - after CleanUp.skp (3.1 MB)

Thanks for looking. I knew it was a problem and tried to work it out. Hence tall the free hand drawing that I did. I’ll check out your model in the slicer and see what it says.

Hi,

I have this problem with many imported STL files that I’ve imported to edit.

The original files will print okay, but importing the STL causes many, many breaks in the mesh. I guess that the edges are so small that SU imports them as 0.00mm.

Does anyone have any ideas about how I can import these models without these problems (is there a way of scaling STLs before importing? Some of the models have taken literally days to repair.

Many thanks,

Uncle Paul.

Set the import units to meters to avoid the tiny faces issue. Set the units in the import options window.

By nature, .stl files are unitless so you need to tell the importer what units to use.It works fine to work in meters in SketchUp and that helps to create the missing faces due to extremely short edges.

DaveR,

Thank you so very much - I wish that I had asked 3 months ago - such a simple solution that escaped me.

Thanks again!

Uncle Paul.

You’re welcome. FWIW, this works going from .skp to .stl, too. No need to scale down the model. I modeled this little screw jack from the early 1900s the other day. I used meters instead of inches in this case.

When imported into the slicer, I told it the dimensions are in inches instead.

1 Like

Perhaps Skimp could help if you do this process often.

1 Like

So I made it a solid but hacking off the bottom and importing the stl I orginally used in. I changed the setting to meters on the import and it came through no problems. then I added lines to keep it together… Thank you to all the help.