Trying to make different sketchup scenes visible in Layout viewports - struggling

layout

#1

I’m trying to create a floorplan of a small house via Layout. The slightly tricky thing is that I have a couple windows that are higher on the wall and relatively short, such that when I do a section cut the cut plane will go through and past those windows before it gets to other windows and doors. So those windows do not show up in the section cut.

So, I figured I need to make two scenes, one of just the wall with just the two windows in the cut. And the other scenes with a section cut of all the other windows and doors. No problem. But when I send to layout, and then copy and paste the scene, and then switch that stacked copy to the other scene and make layers out of them, the scenes are not inclusive of the other scene. In other words, with any layer I have selected, no matter how I stack the layers, it only show that scene and does not include the other. I guess I was thinking the layer with the two windows on top the layer with all the windows it would include all visibly.

Can anyone tell me how to do this?

I also wanted to have a 3rd layer that showed the interior walls with a different section fill color but that is not critical.


#2

The easy way is to Reduce the viewport size of the upper windows scene to the size of the windows and stack over the others doors/windows viewport, probably you will require more reduced viewport to show all the upper windows. The scene style in SU and SU tray in LO have to have the same setting than the other windows/doors.

But this depend on how you would like to represent the upper windows on your floor plan.


#3

Are you trying to achieve a cranked section (ie. one that steps up/down in profile)?


#4

I have no idea what this means. “viewport” is a layout term for the layout page or layer of a sketchup scene, right?
I’ve re-read your post about 20 times and I have no idea what you are saying.

I got around the issue by moving the upper windows in the sketchup model down to the level of the other windows. So, I broke my sketchup model so that I could have a usable layout floor plan.


#5

Not sure what you are referring to by “profile”. But I’m simply trying to have a layout floor plan view that includes windows (on the same floor) that are on a different vertical level. Because they are on a different vertical level in sketchup my section cut (in sketchup) does not include both levels of windows.


#6

So here’s a sort of house with window openings at different levels:

And here’s that house with a typical uncranked section plane added:

And here is one with a cranked section plane allowing both windows to show in the section:

Cranked sections are common in architectural drawings but are harder to achieve in SU. But is this what you are after?


#7

You can overlay 2 model views…

Screen grabs of different ways I use this technique:

Windows isolated over elevation. The elevation is behind a white rectangle that has transparency.

Structure is isolated with layers and set over a 3d view of the building. There is a white rectangle with transparency between the SketchIp model views:

2 levels of the house shown on 1 page - this uses 2 scenes with a clipping mask:

I drew a shape and used it for a clipping mask to show the master bedroom level and how it relates to the lower level (to coordinate mechanical chases…)

When I cut the section for the lower level the cars were cut in half - so I created a scene with just the cars on and put it over the garage…


#8

Simon. Yes, exactly.


#9

Thanks bmike, I’m going to try that when I have a chance.


#10

Yes, the viewport is the container of the image sent from SU (hopefully from scene). It is recommended to assign each layer a single viewport, in order to facilitate its management and control.
Hope the image with the viewports selected help to understand what i mean:

  • Send from SU to LO scene 1 (normal windows).
    Next steps are from LO
  • Copy/paste scene 1, change layer and change to upper windows scene (Scene 2).
  • The layer for scene 2 must be upper the scene1 layer.
  • Make sure to check preserve scale on resize on sketchup model window.
  • while scene 2 still Selected, hover the mouse over the blue box. When the cursor change to move mode, you are ready to resize the viewport by L-Click+Hold.

#11

Charevir,

I did exactly as you are describing, but in Layout I’m able only able to see on layer at time. In other words when I create 2 separate scenes like you show, and then create 2 layers in Layout of each of the scenes, when I stack layers I can only see the top layer. So, in your example if I have scene 2 stacked over scene 1 I cannot see the window from scene 1. What am I doing wrong?


#12

Did you resize scene2? because the 2 scene have the same style in SU the upper scene will override the lower one, this is the reason I resized the upper scene.

Try to uncheck the background box on sketchup model window in LO.

An image will help the audience to understand your problem


#13

Make sure the ‘background’ is turned off, so you can see through the model view that is on top.

Also remember that the layers in LO work for visibility as they are stacked - so things on top will appear above things at the bottom of the list.

05%20PM


#14

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.