Trying to install Pro 2023

Just bought an downloaded Sketchup Pro

I had a trial version which I had uninstalled and was using the Web version… Upgraded to PC Desktop Version today

Downloaded the downloader and ran it as normal logged in user.

The downloader launches an msi installer I think, which unexpectedly fails with an error that a feature I am trying to install is on a network resource that is unavailable. The source appears to be an msi in my %appdata%\local\temp folder, Which is not there.

What do I do now?
Is there a way to download the msi installer?
Is there a way to clean my system entirely of Sketchup inclduing all Registry entries? ANd to then try again?



Try right clicking on the installer and choosing Run as administrator while logged in as your normal user.

Just did that. Exact same result :frowning: sad panda

See if this helps.

There are other threads related to this issue with the .msi file, too.

Bad News / Good News

I couldn’t try you suggestion because Sketchup never finished installing…


I ran regedit, then find->Sketchup
I found an entry for the msi it was trying to locate, and deleted the entire tree.

Ran normal installer again (as admin) and it installs fine. And it seems to run and work fine too.

Thanks for help, much appreciated!


1 Like