Trying to edit the Style

hello, trying to edit at Style, but the edit function is greyed out and I’m not able to do so. Any suggestions?

click on the small black house first.
it’ll bring you to the styles in your model, not the default style library.

You can only edit styles applied in your model

wait no, it’s late, my head is elsewhere, you should be able to edit anyway.

can you show us a screenshot of the faulty “edit” function ?

1 Like

Hi thank you. I am already in the small black house. Still no success - just a greyed out section not allowing editing


Do you get the same result if you select the other style in the model?

1 Like

That’s strange it says that you haven’t selected any style, can you create a new one by clicking on this icon? :point_down:t3:

1 Like

Well I did the good old ‘sign out of Sketchup, shut everything down, reboot my system, start everything up again’ trick and it is working now.
Thanks for all your insight and teaching me to look deeper into things while trouble shooting. Even though it’s such a headache during these glitchy times - I sure do learn a lot in the process.

thanks Francis, I did click on that icon and even though it added another style - it was the same scenario.

Hi Dave, yes it was the same for any style. But my reboot fixed everything - for now anyway.

well, good it’s fixed. it’s weird, because normally you’re not supposed to be able to NOT have a style selected. Your file always has a style, and this style is always selected by default.

Never seen that before, good a reboot solved it.

Don’t forget kids, when in doubt, reboot.

1 Like

Good morning Nab, yes what you said for sure.
I was able to jump from one style to the other in my model like normal, but as you saw, the style menu wouldn’t allow an edit or even recognize that I had chosen a style.

Leave it to my MacBook Pro to find the most finicky of issues. I’ve noticed that Mac has another operating system update, but I’m staying well away from that. Maybe I’ll update with both Sketchup or Mac operating system a year behind anyone else from now on. :thinking::laughing:

1 Like

That’s usually a Windows fix. :slight_smile:

That’s a wise decision, sketchup 2023 doesn’t support MacOS Sonoma, and it will never support it, sketchup and MacOS newer versions are between 3 and 5 months apart. Plus, you won’t have to deal with bugs in the newer MacOS that usually appear in the first few months.

1 Like