Editing a style with SU 22 on Windows

I am using SU 22.0.354 on Windows 10.

I open the Style tray then I click on Edit then on the coloured square to the right of Sky,

All the menus are greyed out and nothing pops up to allow me to change the colour.

I can only do an Escape to get out of this.

Is there something I forgot ?

I remember when using previous versions on PC that it was quite simple to edit a style.

You can’t edit a Style that is located in an external library.
Firstly you need to load it into your model’s Styles, after that you can edit it - and save the changes to it in that model’s Styles.
After that you can choose to save the Style outside of the model, into your own Styles subfolder, which can be linked in your SketchUp Preferences for file locations.
After saving the Style externally it can be loaded into future models in its updated form…

I open the Style Tray.

I select “In Model”.

I choose any one to the styles shown.

I click on the Edit Tab.

I can control the check boxes for Sky and Ground.

As soon as I pass the mouse on the square to the right of a check box, its look like I am depressing it. I click to edit it and nothing happens except for all the main Menus of SketchUp being greyed out.

any chance you have two or more screens ? and that this method helps ?

it sounds like the window appeared outside of the screen, since you have to press esc to exit it. Windows likes to do this, happened to me the first time I used 2 external monitor on my laptop, did the trick, never had to complain after that

Doesn’t happen for me.
Everything works fine.
Was SketchUp installed on the PC properly ?
You must right-click on the installer’s exe file and ‘Run as administrator’.
Choose Repair when prompted.
If you run the installer’s exe file in any other way it can mess up permissions and cause unpredictable problems.
Having admin-powers as a user is NOT the same as running the installer properly…


I tried your procedure but it didn’t work with M. I used L since my system is in French and I need to press the Return key to validate before being able to move the hidden window with the arrow keys.

Another procedure that works for me is the following:

I disconnected my second screen from my laptop, started SU and then, the dialog window for colour edit appeared on the laptop screen

I reconnected the outside screen to my laptop and now the dialog window appears on the laptop screen even if I move the modelling window to the other monitor.

yes, I remember trying on a visible window first, to be sure I understood the method. and yeah, L in french, for dépLacer (ughh)

yeah, that’s the source of the issue, somehow some windows will loose their bearing when going mono-multi monitor, for me it was the pref panel and the 3d text. go figure. replacing the window in its place completely solved it. for now :slight_smile:

No. Absolutely not. You just need to follow the sequence as it is. The only - language related - difference is a letter that you need to hit at step 3. :wink:

Problem solved.

The only strange thing is that the window was not visible neither on my laptop screen nor on the external monitor.