Trouble creating Note 5 aluminum rim - Convex curved shapes (RoundCorners issue, follow tool is a no go)

help

#1

Hey there!

note 5 rim (user attempt).skp (812.3 KB)

The picture and sketchup file in this submission is not mine, and is a users version of a Samsung Galaxy S6 phone. I’ve erased everything but the rim for simplicity, and it seems the user was having basically the same issue as me with some overlapping (although he/she was able to get somewhat of a bevel in there somehow).

My goal is to perfect this curved rim and add a beautifully blended bevel along the edge of that rim. I am trying to use this method to create a complex Samsung Galaxy Note 5, which is basically the same shape.

How did the user manage to create such a variation in rims curves (the top curve being different than the side, yet it blends so nicely around the corners??!), and also manage to add a bevel to such a curve?

I’ve used RoundCorners for simple shapes successfully, and have managed to create a very basic mesh that I could use to subtract from a rectangle, but things get way out of hand when trying to add a bevel. RoundCorners seem to give me overlapping no matter how I scale or which level of offset / points the curve has, and the followme tool creates too much overlapping to use the 3d shape as a subtract element in order to cut it from the main shape manually.

Any help is much appreciated!!


#2

have you tried Fredo’s NEW and improved round corner plugin?


#3

Yes I’m currently using 3.2, the Apr 18th build (latest AFAIK)


#4

The new is called Fredocorner

https://sketchucation.com/pluginstore?pln=FredoCorner


#5

@whiterabbitdesigncompany was referring to FredoCorner (currently V 1.1f).
Have you tried a combination of BezierSpline and CurviLoft for the corners?


#6

Thanks for the clarification on the Fredo tool name !!


#7

Have you seen this tutorial with the modeling of a phone?
In SketchUp, you might need to use the Vertex Tools plug-in.


#8

Something like this…


#9

Any idea why im getting an error “Catena pursue” 3 times followed by a “Kette brane pursue” error message?

Untitled-5


#10

Nope! I do not know what that means.
What language is your system and SketchUp?


#11

That are error messages from FredoCorner, you should report them in the extension topic at SketchUcation.