RoundCorner plugin issues


#1

I’m having issues with the plugin RoundCorner. I’ll attach screenshots, but I’m trying to round the corner of a curved object, and when I hit enter with the desired dimensions, I get a bunch of deleted faces, etc. Does anyone know why this is happening or how to fix it? Thanks :smiley:


#2

It’s hard to tell without seeing the SKP file and knowing the settings you’re using with Round Corner. At the moment the forum seems to have a problem with images. Maybe you can post the SKP or share it via the Warehouse and give us the link.

Very likely though, the issue has to do with the model being small.


#3

Wow! Thanks for the fast reply! Yes, I am having trouble uploading images. I’ll upload a couple screenshots, as well as the actual model, and generate a public drive link. Allow me a few minutes.


#4

Here we go: https://drive.google.com/folderview?id=0B-WP2pX142ZsQnNvVGNpRWt1b1E&usp=sharing
Also, I experimented with making the model much larger, as I suspected the same thing, but the same results occured. It gets even worse with the line below the highlighted line in the first picture.


#5

I’ve been playing with it. I think the problem might be related to the slope of the bevel changing around the shape. I tried running a profile around using Follow Me. I started on a straight long side and with the profile drawn to fit there, it doesn’t fit at the ends.


#6

Hm. Anything I can do about that?


#7

Well, I kind of wonder if the radius shouldn’t be variable around shape since the bevel is rolling. Take a look at this version of the file and see if it works for you. I wound creating the radiused portion using follow Me and then hand stitching the bevel back in all the way around. I expect you could also just hand stitch where the faces get deleted with Round Corner although there was some bad geometry generated at the corners, too.

You might be able to use Curviloft or one of TIG’s extrusion tools to avoid the hand stitching but I was too lazy to hunt around. Also, sometimes it’s just easier to do things by hand than to get things setup so you can use a special tool.


#8

That looks good! I don’t think the slope of the bevel changing is the problem, as I made the rounded corner 1/20th of the size I previously used, and it turned out ok. Just when I make it larger the issues occur.


#9

Maybe this is a question for Fredo.


#10

What is his username?


#11

I guess it’s Fredo6. Might be easiest to ping him on Sketchucation.


#12

I solved the issue to my problem. I previously used a plugin called shapebender to create the curved surface I was working with, which did indeed cause the slope of the bevel to change I think, or something along those lines. I recreated the curved surface without the plugin, and bam! Everything began to work out. :smile:


#13

Good enough. I was thinking you could probably do that all with Follow Me, too.


#14

Follow Me works on a planar path. FollowMe and Keep or Eneroth Upright Extruder will work on a 3D path.