How can I make a bevel around a curved surface?


#1

Hi… I want to make a bevel around a curved surface…

Normally I use Fredo6’s “RoundCorner” plugin which often helps… But in this case it keeps telling me I have overlaps and it creates some random geometry.

If I then try to clean this up, I get great holes in the model:

Interestingly, at the other end of the model, the “round corner” worked perfectly… So I wonder if I started again, it might be OK… But this isn’t the first time I have struggled to do this and would like to find a better way.

Is there a better way to achieve this? Or better still, is it possible to “clean up” after applying the RoundCorner tool?

Here is my STL if its any help

Starting Again 1.skp (1.1 MB)


#2

The effect you are seeing happens when the profile you are using is too large compared to the length of the path’s arc segments near a sharp corner. It can also happen when using SketchUp’s follow-me Tool. Often you can improve the result by using a curve with fewer segments for the path, or by replacing a few segments near the corner with a longer single edge. Sometimes it also helps to scale the model up to a larger size before doing the operation, as SketchUp’s failure to create small edges can aggravate the problem.

When this anomaly occurs it can indeed be very fiddly to clean it up!


#3

I tried all the options in RoundCorner… If anything, changing the number of segments makes it worse.

I have just noticed something… When I select the edges I want to round, the tool already marks a little extra geometry:

Where as the other end of the model does not:

In fact, as soon as I click on that edge in RoundCorner, I get this extra green line… Where as if I do the same at the other end, I do not… So there is specifically something wrong with my model at this point.


#4

Your model is not symmetric, which is why the two corners are being treated differently (see attached screenshots). The final segment near the left corner is very small compared to the profile and dangerously close to SketchUp’s small edge problems. That’s what is messing up round corner’s algorithm.


#5

Ahhh. I did try to make it symetrical, but due to it being curved, i just did it by eye to make it as close as possible.

I didn’t think that symetry had anything to do it it, as even if i only try to round “That” corner on its own, i get the same issue.

I did think about the small edge problem, so i scaled it up to x10 and x100 and it was exactly the same.

Any thoughts on how i fix this? Is there an easy to to fix the symmetry?

Edit: I just tried it again 1000x bigger, and still get exactly the same issue as soon as I select that corner…


#6

Here you can see how tiny that edge is compared to its neighbor.

I’d delete those two edges and the corresponding ones on the bottom arc of the surface (after exploding that arc so you can select the edges), then redraw a single edge from the corner to where the far end of the longer edge was. The face will disappear when you delete the edges, but will be restored when you draw the new, longer edge. Nobody is likely to notice the very slight asymmetry afterward.

The alternative to get perfect symmetry would be erasing half the shape (which may be a problem unless there are vertices at the exact middle on all arcs) and then making a mirror copy of the remaining half and joining the two parts back together.


#7

Cheers… To be honest, I am struggling to understand what you are showing me there. Is there a ‘too’ which shows those black/dark markers?. I have found a solution… I rounded the offending corner…

And now I don’t get any problems… This I think works for my application (which is a tiny 3d printed part where dimensions arn’t important)

I still wish I understood a little more about how Sketchup works, but I think this solution is fine (And actually better).

Cheers.

Jon


#8

I went back to the original and after zooming in could see that tiny ‘slither’… So drew a line across the top and “pushed” the think strip down to the floor and thats fixed it.

I am not sure if this makes sense, so here is a picture (in this I have only just started pushing it down)

So I think it makes sense… How exactly did you spot this? Whats is that tool that shows the ends in black (As per your photo above)?

Thanks again

Jon


#9

To get those blobs at the ends of edges, open the Styles window, select and edit the current style and enable Endpoints in the edges tab.

I spotted the problem by zooming in close and examining those corners based on experience with small edges near sharp corners causing this kind of effect. Turning on the edge endpoints just makes the situation more conspicuous.