Triple-click selects all the connected things


#1

Hi All,
Have recently upped to SU2017. I have noticed that the Selection Tool does not allow a Triple-click selects all the connected entities. Am I missing something here, or has this very useful function been deleted?


#2

I can only say that it hasn’t been deleted.
Perhaps some adjustment in your pointer settings would help.

Shep


#3

OK, Well I’ve tried three difference pointing devices. They all select all on triple in SU2016, but not in SU2017.


#4

The only other thing I can think of is, once I plugged in a usb 3.0 thumbdrive that really interfered with my wireless keyboard and rodent.


#5

Hmmmmm. I have just pulled everything out. The single and double click works but not the triple. The context menu allows access to this (Select > All Connected) and this works, but there is no way to assign a shortcut key to this function as a work around.


#6

I notice also that speed seems to be a factor. If your clicks are not fast enough you may see this problem.


#7

Thanks Shep, Yes, I do understand this. However, no matter what speed, etc. It works in SU2016 but not in SU2017. I have tried adjusting the pointer settings, all to no avail.

I was just hoping some one might have come across this. grrrrrr. :slight_smile:


#8

Two things I would suggest.
Update the driver for your graphic card.
Repair the installation by right clicking on the installation .exe and select Run as Admin, then repair.


#9

Thanks Box. GPU card recently updated will re-install again. Are you suggesting reinstall / repair of SU2017?


#10

Don’t need to reinstall the driver. The suggestion to reinstall/repair SU is related to how you installed SU to begin with. SU needs to be installed by r-clicking on installer > Run as administrator.

The method @Box described is an alternative method to reset file permissions required by SU in the event the program was not installed as an administrator - which may or may not work. Some computers needed the program to be uninstalled and reinstalled as administrator for this step to be effective.


#11

What does the triple click instead?


#12

Yes there has always been (if you can remember this.) The context menu items are active when in the correct CONTEXT. (Hence the name of the menu.) The menu appears in two places. Attached to the mouse cursor, and at the bottom of the “Edit” menu (where it’s sub-menu name will be the name of the object selected.)

In your specific case the context is a “item” selection. Select a face, and then look at the Edit > Face menu, you’ll see a Select sub-sub-menu, with a All connected menuitem.

So this is what you need to do whenever you wish to assign shortcuts to contextual commands. You need to first put SketchUp into that context, so that the commands will be added to the menu (“on-the-fly” so to say.)

Then open Preferences > Shortcuts and scroll down the commands to the “Edit/Item/Select/All Connected” command and assign yourself a happy shortcut.


#13

Is this a Windows issue generally? I have no trouble with triple-click on Mac in SU 2017.

Or is it specific to the OP’s machine/graphics driver/SU Installation process?


#14

Hi All, and thanks for your timely suggestions.
I have reinstalled SU, GPU drivers & restarted W7pro (5 times) and guess what - Fixed. So I can’t really say what solved it, but I suspect it was a w7 op system issue.

M


#15

@john_mcclenahan, right off, I cannot remember encountering this particular issue before. But it seems to be a Windows issue.


#16

I’ve run into the same problem but only intermittently. What worked nearly 100% of the time in 2016 only works maybe 1 in 5 tries in 2017. I’ve started using the right menu select which is major reduction in work through speed.

And yeah, it started doing it on both computers and I’ve tried a variety of mice and mouse settings.


#17

@Codger, For me the issue resolved itself after driver and app reinstall and several restarts. this is clearly a way that windows pays (or doesn’t) with SU and other hardware.

Having said that, I’m rethinking my progression to SU2017; too many issues that are now there that were no-issues with SU2016. Dimensioning in LO is the biggest problem (but that’s for another thread). :frowning:


#18

Your mention of LO made me realize I should add that I use Make. Just
for those compiling anecdotal data for these problems.


#19

Check if you open Outliner, then close it. Window / Default Tray / Outliner.

I had same problem and found out I had my Outliner Tray open. Close it and not only triple click work again also my viewport performance much much faster.

Regards,
T


#20

I am having trouble with Triple click in SU 2018. I have tried changing mouse settings and reinstalling/ repair and changing Outliner as described above and nothing helps.
SU Version 18.0.1.16975 64 bit on a Win 10 64 bit machine running an Intel HD 4000 graphics card. Triple click was working but quit for no known reason.