Trimble Won't Send me my access information

I purchased a year of SketchUp Pro on 6/25/20 and have been unable to use the software i paid for in full. I have tried contacting the clowns at Trimble/SketchUp and no one returns my calls or emails.
Following the instructions and links they provide to get access continues to lead to the same error webpage. Is anyone else experiencing this???

1 Like

I don’t think they have clowns working for them.
(I’m trying to envision how that would look like)
Have you checked your spam folder yet?
Also someone may provide you with a link to ‘sales’, @colin maybe?

If you purchased

Then you shouldn’t be expecting any sort of e-mail with “access information”. You simply open SketchUp Pro and sign in with the e-mail address and password you used when you purchased the software under the Subscription tab.

When you open SketchUp, click on License and then Subscription then Sign In.

When you are signed in it should look something like this:

I was the one who the salesperson was chatting with while giving you directions over the phone. It was lucky really, because I wasn’t on clown duty until later in the day.

There was something interesting about your case that will help other people in the future. There was an error showing when trying to activate the account, but I could tell that the account was already activated. Clearly we should have a message more on the lines of: “your account is already activated”. I will pass that issue onto the appropriate team.

Your flagged post was mostly right too.

4 Likes

How many accounts are you planning to open!?

1 Like

:laughing: :+1:

nice humour

2 456 789 234 566 890 234

I have an App for that:

1 Like

It’s not working.

Trying to be a --art---**, ain’t you?


oops!, sorry, it’s only you Mike.

(is this also going to be flagged?)

Do you have an app to flag ? :laughing: