Trimble Scan Essentials - Difussion plugin

Hi all

I just installed Sketchup Difussion, to test it out. When I open other sketchup files to work on (I tend to have a couple opened at the same time), I am having to accept the license agreement for Trimble Scan Essentials (I have no idea what this is), and then a window with Load Errors pops up:

rror: #<Errno::EACCES: Permission denied @ apply2files - c:/users//appdata/roaming/sketchup/sketchup 2023/sketchup/plugins/su_pcp/bin/27/SUPCP.so>

C:/Program Files/SketchUp/SketchUp 2023/Tools/RubyStdLib/fileutils.rb:496:in `unlink’

C:/Program Files/SketchUp/SketchUp 2023/Tools/RubyStdLib/fileutils.rb:496:in `block in copy_entry’

C:/Program Files/SketchUp/SketchUp 2023/Tools/RubyStdLib/fileutils.rb:1513:in `wrap_traverse’

C:/Program Files/SketchUp/SketchUp 2023/Tools/RubyStdLib/fileutils.rb:1516:in `block in wrap_traverse’

C:/Program Files/SketchUp/SketchUp 2023/Tools/RubyStdLib/fileutils.rb:1515:in `each’

C:/Program Files/SketchUp/SketchUp 2023/Tools/RubyStdLib/fileutils.rb:1515:in `wrap_traverse’

C:/Program Files/SketchUp/SketchUp 2023/Tools/RubyStdLib/fileutils.rb:1516:in `block in wrap_traverse’

C:/Program Files/SketchUp/SketchUp 2023/Tools/RubyStdLib/fileutils.rb:1515:in `each’

C:/Program Files/SketchUp/SketchUp 2023/Tools/RubyStdLib/fileutils.rb:1515:in `wrap_traverse’

C:/Program Files/SketchUp/SketchUp 2023/Tools/RubyStdLib/fileutils.rb:1516:in `block in wrap_traverse’

C:/Program Files/SketchUp/SketchUp 2023/Tools/RubyStdLib/fileutils.rb:1515:in `each’

C:/Program Files/SketchUp/SketchUp 2023/Tools/RubyStdLib/fileutils.rb:1515:in `wrap_traverse’

C:/Program Files/SketchUp/SketchUp 2023/Tools/RubyStdLib/fileutils.rb:494:in `copy_entry’

c:/users//appdata/roaming/sketchup/sketchup 2023/sketchup/plugins/su_pcp/pcprootproxy.rbe:165:in `module:SUPCP’

c:/users//appdata/roaming/sketchup/sketchup 2023/sketchup/plugins/su_pcp/pcprootproxy.rbe:10:in `’

C:/Program Files/SketchUp/SketchUp 2023/Tools/extensions.rb:197:in `eval’

C:/Program Files/SketchUp/SketchUp 2023/Tools/extensions.rb:197:in `require’

C:/Program Files/SketchUp/SketchUp 2023/Tools/extensions.rb:197:in `load’

C:/Users//AppData/Roaming/SketchUp/SketchUp 2023/SketchUp/Plugins/su_pcp.rb:24:in `register_extension’

C:/Users//AppData/Roaming/SketchUp/SketchUp 2023/SketchUp/Plugins/su_pcp.rb:24:in `module:SUPCP’

I am assuming this is linked to that Difussion plugin because everything was fine until I installed it. Any ideas? I have found another thread with a similar issue but it is from almost 2 years ago, not sure it might be the same. Thanks in advance.

I use Sketchup 2023

Scan Essentials (SE) is an extension for working with point clouds. It appears that the error is related to SE, not SketchUp Diffusion. If you don’t need SE, you could try disabling it in the Extension Manager (Extensions → Extension Manager).

1 Like

Thank you! Done and now I have no issues.

1 Like

Scan essentials works great with sketchup diffusion though

If that’s the case, is there a way to get around the error pop up window?

Disable Scan Essentials in the Extension Manager.

Scan Essentials requires a Studio subscription. if you just have a Pro subscription it won’t work.

1 Like