Trimble Connect not working in Sketchup Pro

The only menu item that works in File menu -> Trimble Connect is “Launch Trimble Connect” which works and launches the website as normal. Logging in whilst there does not make the other menus work when I go back to SketchUp.

All the other menus “Open Model…”, “Collaboration Manager…”, “Publish Model”, etc open a window briefly, then it just closes. There’s no error message on screen or message to tell me to buy a subscription. It just closes.

I have a classic licence. Is this something that only works in the subscription version of Pro?

I had a look at status.sketchup.com and there was an outage today, but that page doesn’t seem to tell you if it’s up right now or not.

You have to publish your SketchUp model in a project , first.
Maybe that message pops up under active windows

Publish is one of the menu items that don’t work. There’s no messages popping up under the SketchUp window, I just checked. The only time I get an error message is if I try and publish a model that hasn’t been saved yet. If I save it, then try and publish it, the same window pops up then disappears.

Hi there, I am having the same problem as you describe… has there been found a solution ? or is there a little box, hidden somewhere you have to put a x in !!

No solution yet.

I’m going to contact support about this. It must be supposed to work on a classic licence as it’s working on my laptop with the same licence. It works there on Mojave 10.14.6, but not on my desktop on High Sierra 10.13.6. I’m not saying it’s tied to the OS and I see that you’re on windows, so OS is probably not the problem.

I tried deleting caches at:
~/Library/Application Support/Caches/com.sketchup.SketchUp.2020
but it made no difference.

I’ve tried disabling all extensions except the native ones: Advanced Camera Tools, Dynamic Components, Sandbox Tools, Trimble Connect. It still doesn’t work.

I even tried disabling everthing except Trimble Connect and even that didn’t help.

I’ve got it working again now. I had to log out from my Trimble account in Sketchup by clicking the icon at the top right of the window, then sign in again with my Trimble ID.

I think this was something to do with me being signed in via google on this computer years ago and it’s somehow still saved somewhere, despite a new version of SketchUp and only signing in there with Trimble.

Thankyou for the tip, Will try it later when I return to my pc… great to see forum works…