TrimBIM Not Importing into Sketchup. Read-only error message

I have converted a dwg to a TrimBIM and tried to import the TrimBIM into SketchUp. I get the following read-only error. I do not have the file open to cause a read-only error. Can anyone please help with this error or tell me how to load theTrimBIM into SketchUp?

Thank you,

Please attach both files (dwg and trimbim) in order to be helped.
And also please delete the other post messages. Triple post is against the forum rules.

1 Like

Just a hunch , but is the file set to read only?

1 Like

Probably, the location to where you are ‘converting’ (Businessname Onedrive?) has some restrictions.
Set the extensions to be visible in Windows explorer and open properties to see the details. Try a local location on your own device.

FWIW, the ‘different’ sections are all the same size, so probably also the same trimbim-file.
What exact procedure did you follow for exporting the different kind of sections? One can only download the full Trimbim from the web browser, partially or combined files can be exported from the desktop app.

I apologize for the multiple post. I have deleted the other post. I was unsure the best thread or place to post and I was unaware of the rule against multiple post. I will not make multiple post again.

I have attached both the dwg and the TrimBIM. Pretty sure the dwg is not a read-only file unless the original file is protected in a way I am unaware of. The original dwg file I am working with is from the NCMA published details. I have “saved as” the dwg several times and repeated the process TrimBIM process with the same read-only results.

Thank you for help and the files are attached.
Glenn Richardson

Ps. TrimBIM files are not authorized. How should I get the files posted?

You have not attached anything. You can share a link to the file on a cloud service.

I used the following procedure to try to load the TrimBIM file into SketchUp.
I saved the dwg as a 2010 version dwg on my desktop to make sure the onedrive location was not a problem. Uploaded the dwg to web Trimble connect. Synced Web Version of Trimble Connect to Windows Desktop Version of Trimble Connect, Right clicked from Windows TC and converted dwg to TrimBIM. Used SketchUp import to import TrimBIM and the read-olny message appears.

I have used this procedure with another TrimBIM from a surveyor file and the TrimBIM imported so the problem must be with the dwg.


On the way

Your dwg opens perfectly in SketchUp 2024

The same with trimbim file:

You are opening the TrimBIM? I use Sketchup 2024 and I get the read-only error. What procedure are you using to open the TrimBIM? SketchUp import?

I can open the DWG but not the TrimBIM.

I drag the file to SketchUp. Make sure your file is on your PC and is not read only

Sorry my questions seem basic.

When I drag a dwg or TrimBIM to sketchUp, I cannot drop a file into the SketchUp drawing. I get a red circle. How do i change settings to allow drag and drop?

The dwg will open for me in sketchup by using File, Import, but the TrimBIM says it is read only. I do not know how on windows to make sure it’s not a read only other than checking properties and opening the file in AutoCad to see if the file is read-only. What should I do to check my system since it works fine on your SU 2024?

This is a recording of drag & drop.


Thank you for your help. I found the read-only issue in the file properties and now am able to import the TrimBIM.

I am interested in dragging and dropping dwg and TrimBIM files into SketchUp since my SU 2024 will not accept dragging these files.

Again thank you.

1 Like

It shouldn’t be something related to SketchUp but windows. I have tested in a windows 11 machine and it works too.

Please mark the topic as solved if you don’t mind.

Thank you

That’s not relevant.

That’s not necessary, since you have the desktop app. This will convert it faster and locally.

How exactly? Within the desktop version?
There is a setting in the webversion Settings > Project Sync setting were you can control if the file is set to read only, by default it should be the top one, though.