Trim tool converts trimmed component to a group

2016

#1

I’ve noticed that when I use the Trim tool - trimming one component with another - the component that gets trimmed will get converted to a group, named Difference, and other instances to the component are uneffected by the trimming.

Is there a way to get the Trim tool to work on all instances of a component?


#2

Although you did not mention this, you are using the solid tools set, which are only available with SU Pro. A brief tut on the use of the “Subtract and Trim” tool is offered here: Subtract and Trim Tool Tut


#3

Not the native Trim tool. For several years I’ve been asking to have the Solid Tools changed so that they don’t convert components to groups. Any other tools used to edit components result in all instances of the component getting edited but the Solid tools don’t. It seems like a huge inconsistency in their operation.

There are a couple of options, however. Jim’s Trim and Keep which is available through the Sketchucation Plugin Store (at no charge) and Eneroth Solid Tools from the Extension Warehouse. I mostly need the Trim tool and use Jim’s plugin because it operates in the same order as the native tools. Eneroth Solid Tools reverses the order. Both leave you with components.

One thing to be aware of with Jim’s Trim and Keep is that it leaves the original version of the component in the In Model library. This is useful if you need an untrimmed version later but if you don’t, you should run Purge All to get rid of the extra copies.


#4

I agree its operation is inconsistent - and thanks for the suggestion on the plugins.


#5

Encountered the same problem of components turning to groups and then tried Eneroth Solid Tools and they worked great! Thanks for the suggestion. Surprised Sketchup hasn’t changed this, components changing to groups is very frustrating.


#6

Sorry to bump an old topic but looks like it is still relevant. I just created quite a mess and wasted so much time trying to figure out why my components turned into groups. There are now many components in my model that are now groups. The names are also gone. This is going to take so much time to clean up, man to say I’m disappointed is such an understatement.

The solid tools should not do this, why has this not been addressed? Dave R did you ever get a reason from developers as to why they have this glaring departure from expected behavior?

Using pro 2018.


#7

Nope. No answer. Of course Eneroth Solid Tools takes care of this issue so I suspect it’ll never be changed in the native Solid Tools.


#8

It is a surprising oversight in my opinion. There has been such good and consistent development since the @last days. I feel bad for all those that find this out too late or worse never find out what the issue is.

Trim and keep doesn’t show up for me in the extension warehouse (like you 95% of the time all I need is trim and I do like being able to trim multiple items with the first selection staying constant). I’ll give the eneroth tools a try.


#9

Trim and Keep was never in the Extension Warehouse and unfortunately it seems to be no longer available. The author has pulled it from Sketchucation.


#10

hmmmm… wonder why. Well I’m glad the eneroth tools seem to be another work around. Like that they also ignore nested components as well.


#11

Booltools 2 also solves this problem…and several others.