Transferring SU activation to a new computer

I want to replace my laptop (MacBook Air) with a new one (MacBook Pro) and want to make the transition with Sketchup 2019 as easy as possible.

How do I deactivate the app in the old computer? Or do I ‘deactivate all’ and then reactivate on my new laptop and my desktop?

Thanks.

Remove the license in the current installation under Help in SketchUp. Then you should be able to install and activate it on the new computer.

Thanks!

I’m at the same place, wanting to install SketchUp on a new computer. (Pretty pumped!) I totally understand how to remove a license from the computer I’m not going to use anymore. The struggle is what site and how specifically to tell Trimble that I want to add a license to the new computer. Everything is geared towards buying a new license…

Install SketchUp on the new machine and open it. You’ll be asked to provide your license information. If that’s a classic license, enter the info you received when you got the license. If you have a subscription, log in with your e-mail and password as you did when you activated it on the other machine. No big deal either way.

Thanks Dave. I tried but the web-site is “temporarily down”. I’ll try again tomorrow.

What web site? I just opened this one and it worked fine.

https://www.sketchup.com/download/all

I was on Trmble. Thank you so much.

image001.jpg

But when I try to sign in to Trimble I get this.

That indicates you havea Classic license (and everyone else has your Classic license as well, since you’ve displayed the whole thing in your post. You should edit the post and get rid of the screenshot.)

Sign in with the Classic license instead of trying to use a subscription.

In the license panel click on Classic and then Add License…

Well that worked. Thank you. Now with SketchUp running on the new computer I can’t see the cursor. I can in all other programs. This is what I purchased.

To what do you have display scaling set?

Have you updated the graphics drivers lately?

Look in Window>Preferences>OpenGL. Is Use Fast Feedback enabled or not? Try changing that setting and see what happens.

Which Intel Iris Plus GPU is it? Looking at the benchmark sites Iris Plus GPUs don’t rank real high and that could be a problem depending on your models.