Toolbars duplicating issue

Hi Guys. Need some advice. My SU 2020 had some toolbars duplicating problem. I attached screenshot on my workspace and my PC specs for reference. Thanks in advance.

Cool!

So the first question is how did you install Sketchup 2020? Did you right click on the download installer and choose Run as administrator from the context menu?

At this point I would suggest quitting out of SketchUp, find the installer (or get the latest one if you don’t have 2020.1) right click on it, choose Run as administrator and then choose the repair option if it is presented.

Hi Dave.
To answer your question, Yes, I right click on the download installer and choose Run as admin for installation.

Alright then, I will try to find different installer, perhaps the latest.

Try sketchup.com/download/all

Thanks Downloading now…will give an update.

1 Like

After you install it, shut the computer down and do a cold reboot. Then open SketchUp.

Unfortunately, It didn’t work. :cry:

Weird. I bet @colin knows exactly what the problem is.

Yeah, it is weird. Hope to hear from @colin soonest.

Don’t know why I didn’t think of this earlier. What happens if you go to Window>Preferences>Workspace and click Reset Workspace?

Yeah, Done that couple of times, but still duplicating the toolbars. tsk,

I have recently helped someone with issues about solid tools being empty. Deleting preferences or resetting workspace didn’t help. What does fix it is to remove the workspace values from the registry. For 2017 that should be here:

Computer\HKEY_CURRENT_USER\SOFTWARE\SketchUp\SketchUp 2017

Delete ‘Workspace’ in there, and reopen SketchUp.

Hi there @colin done Deleting the workspace but it didn’t work.

Btw, the duplication of toolbars happened whenever I drag them, even the materials toolbars on the right side also duplicates.

The path I gave was for 2017, I read your profile and not what version you had asked about! But, you had found the right place.

I wonder if it’s a GPU issue. If you go into Graphics Settings, and Browse to C:\Program Files\SketchUp\SketchUp 2020 then add SketchUp.exe, you can use the Options to switch between high performance and power saving. See if either of the two stops the corruption from happening.

Done tweaking the graphics settings, unfortunately it didn’t work. Tried installing different versions of SketchUp but the problem still there.

@colin but thanks for your suggestion.