Toolbar Icons Launch Incorrect Tools

sketchup
icons
bug
toolbar

#1

In my installation of SketchUp Pro 2017, each toolbar icon launches an incorrect tool.
Pan Icon launches the Zoom tool.
Paint Bucket icon launches the Eraser tool.


#2

Did you install SketchUp properly? by selecting its installer’s exe file icon and right-click > context-menu > “Run as administrator” ?
Simply selecting Run or double-clicking its icon will not set it up properly, and can lead to all kinds of weird problems…

You probably don’t need to uninstall and reinstall.
Close SketchUp.
Run the installer as administrator as explained above.
When prompted choose to ‘Repair’.
Retest SketchUp to see if that helps…
If not, then try a full uninstall, then a new install…


#3

Required
Full uninstall of 2017 AND uninstall of Google Sketchup 8
Now installed and works


#4

Different versions of SketchUp can exist on the same computer, side by side - they do not interact or share data.
So there is no need to uninstall an earlier one.

PS: An exception to this ‘no-interaction’ is found with the v2017 installer to suit the latest dynamic-component su_ extension, which somehow changes the way IE interfaces, which then sets IE to be compatible with v2017 but the DC dialogs etc then fail in earlier versions.
However, getting the latest DC su_ extension RBZ from the EWH and installing it in earlier SketchUp versions sidesteps this unusual glitch across all versions…


#5

Another annoyance is that whatever version of SU you run sets itself as the default app to open .skp files. If you double click a file name (as opposed to starting SU and opening a file via the menu), Windows will use whatever SU you last ran previously. You have to reset the default or use open-with to avoid this.

This behavior is not unique to SU, but since most other apps overwrite the prior version rather than install parallel to it, it’s actually what users want. It automatically avoids trying to open files with a no-longer-installed version.


#6

I run Windows 10 and for testing I run many versions of Sketchup all the way back to SU 7. When I double click on a skp file Windows always opens up the last version of SU that I installed as opposed to the last version of Sketchup that I ran.

A case in point. I had uninstalled SU 2016 but kept all the other versions on my PC and double clicking was opening in SU 2017. Then I reinstalled SU 2016 and double clicking skp file then opens up in SU 2016. Then I had reason to resinstall SU 2017 and now double clicking opens the model in SU 2017 as opposed to any other version of SU that I had previously run while testing.