Toggling solar north in layout

I successfully toggled solar north in Model.
Now I am in Layout.
This feature has not imported itself.

Can someone advise, please ?

The orange north line is like the axes in SketchUp and doesn’t get displayed in LayOut. You could model a north arrow to align with it so that you have some geometry to display in the viewport.

I tried, and the information change about shadows really couldn’t be updated.
I don’t know if that means it?

Thank you Dave.

I am projecting shadows of a building.
It works well in Model with the Toggle north.
There must be some way to import the same feature into layout.

I dont think the old solar north add-on works anymore.

You would need to add some sort of geometry to represent the Solar North line.

The “old Solar North” plugin does work but as I said, the orange line will not show in the viewport in LayOut.

Here’s the Solar North line displayed in SU2019 using the old Solar North plugin.

By the way, please complete your profile with SketchUp version and graphics card.

are you updating your scenes and then your layout file so the revised north shadows are carried over into layout?

gsharp makes a good point. If it’s only the shadows that you are trying to show, you need to make sure you update the scene after changing them and then you need to update the reference in LayOut. And you need to make sure the scene is not modified in LayOut.

The shadows would automatically be updated each time Model is saved and Layout is re-opened.
Model allows north to be toggled so you can keep your drawing on the page the same as say on the CAD file.

I just want the same feature in layout.

As I’ve written twice, the Solar North line will not display in the LayOut viewport. You will have to add some sort of geometry in the model to show the orientation in LayOut.

Unfortunately, the file is too big to upload.

Yes, it is simple to draw a north point.

I am needing to show the shadows cast by the building.

I already know how to geographically locate the model.

I want it on the page whereby the solar north line is rotated.

Upload it to Drop Box and share the link.

There’s a number of problems with your model and your use of LayOut. First, you haven’t used any scenes in SketchUp and you’re using a modified scene in LayOut.

I created a scene showing the plan view of the buildings with shadows turned on. Then I selected that scene in LayOut. Does this show what you want?

Your model needs more help, though. There’s a lot of exposed reversed faces, a distinct shortage of grouped geometry, and incorrect use of layers.

Hello Dave

The shadow on your Layout scene post is for midday.
The north point in the title block corresponds.
That is what I cant achieve.
Posted is the scene that I get in Layout.Layout scene 21 June 12pm…pdf (317.0 KB)

When I open Model the Extension Manager says the solar north extension is unsigned.

Unsigned doesn’t mean that much here. You can trust the extension.

You either have the extension in SketchUp or you don’t. You seem to have it installed.

The extension lets you set up a different (different from SketchUp’s green system axis) solar north by clicking (set solar north) or by entering an angle.
Toggle North Arrow only toggles the visibility of that angle by displaying the orange line or not (in SketchUp)

You set up the right solar north angle for shadows of your model in SketchUp.
Then you set the desired time (either by date and time sliders or by value input).

Once you get that right you create a scene.
That scene is used in LayOut.

If you also want shadows for a different day and/or time you’ll need to set up and create an extra scene in SketchUp and use that extra scene in LayOut.

Solar North can manipulate your SketchUp model’s shadows.

LayOut can only display them by using the (in SketchUp) created scenes.

I set up shadows in SketchUp, not in LayOut and I created a scene in SketchUp for the view of the model. Neither of which you did. As I described previously, create a scenes for the views of the model you need. If you want shadows on, turn them on for the scene. Then select that scene for the viewport in LayOut. That can be done by right clicking on the viewport and selecting Scenes or by going to the SketchUp Model panel in the Default tray and selecting the scene from the drop down list. Do no set the view or make shadow settings in LayOut. Only select the scene.

Scene created in SketchUp with shadows set for noon on 21 March.

That scene selected in the SketchUp Model panel in LayOut. Don’t touch the shadow settings in the LayOut. The only setting you need to make in the upper two thirds of the panel is to select the scene.

As @Wo3Dan says, unsigned doesn’t mean a plugin or extension doesn’t work. Your model shows it is working.