Toggling a chosen layer from the keyboard

layers

#1

Is there any way to assign a keyboard shortcut to a particular layer? SU preference’s shortcut options window only offers an on/off toggle for the layers window. I’d like to hide/show a particular layer through the keyboard, which would make it a lot easier to trace Bezier curves accurately, when modelling from photographs or other 2D sources, which may or may not be opaque (i.e.: won’t let you see your progress). The curves I’m currently using require 4 clicks to define, but I need to compare them to the original for the 2 last inputs. As these are made with the mouse or trackpad, it’s quite unwieldy to toggle a layer from the layers window.


#2

When I am tracing curves on photographs, I just change the edge style making the edges thicker and a different color. This makes it easy to see the line I’m drawing and the underlying image with no screwing around with toggling layer visibility.


#3

I’ll try that… Thanks!..


#4

Yes, there is. (FAIK there is no such solution for any desired layer though)

SketchUp has two special layers: Location Terrain and Location Snapshot.
Both layers are created when adding a location to your model. But since you don’t need to geo-locate your model, it may be better to manually add (type) both layers to your layer set.
Layer Location Terrain is needed to toggle this layer on/off with the ‘Toggle Terrain’ icon.
Layer Location Snapshot is optional to toggle visibility between both layers on/off.
Toggleing is indipendent of what other layers arev currently visible, a big advantage.
Since the icon is listed in the shortcut list you can even speed up toggling by assigning its operation to a shortcut key, just as you requested.
See menu Window > Preferences > Shortcuts > assign File/Geo-location/Show Terrain to a key.

See image: the geometry of both groups could be anything so could also be your 2D source or an image.

As long as the layers “contain” anything they are not purged, for the model is not geo-located.
They could even be part of your template.


#5

Thanks for this, it’s really useful…
Once I figure out the “ins-and-outs”, I’ll probably also use it to toggle the “centres” layer, to which I assign all the centre-reference marks I leave in circle-intensive models.
I’m a bit surprised no extension exists for this functionality…
Stephen.
P.S.: My handle in 3DWarehouse is “glistenUp”.


#6

Follow-up to my previous question:
Worked great with a test file, but further attempts on previous or new work result in a greyed-out “Toggle Terrain” icon in the toolbar. I used the same procedure as was described in your answer, namely:

  • placing the Toggle Terrain “switch” in the toolbar
  • creating a layer labeled “Location Terrain”,
  • assigning the desired entity to that layer.
    What prevents the geolocation toggle from being available? As I said, the first attempt was successful, but I can’t repeat the procedure without understanding the origin of this glitch…

#7

These two layers used to be called Google Eearth Terrain and Google Earth Snapshot.
Since Google “drifted away” from Trimble SketchUp they are now called Location Terrain and Location Snapshot.
I’m telling you this because this method has worked for years (and used it).
Yesterday when preparing the answer I typed Location Terain and nothing happened at first. The r was missing. Adding the r fixed it.
Today, I tried again in a new clean model. The ‘Toggle Terrain’ icon still becomes active immadiately after adding that specific layer Location Terrain. Even with not yet having it assigned to anything.

Be sure to type the layer name exactly as Location Terrain (no typos) and it should work.


#8

Can anyone using SketchUp 2017 Make (or Pro) on Mac OS 10.10.5 Yosemite confirm that manually adding a layer called Location Terrain does not activate the ‘Toggle Terrain’ icon to toggle this layer on/off? It works for me in Windows 10 for SU 2017 Make and has always worked in previous versions of SU.
@franquin has had problems with this after having success the first time. The icon does not become active. Is this a 'Mac only’ issue?

p.s. only layer Location Snapshot also sort of activates the icon but does not let you toggle the layer on/off unless Location Terrain is added too. But this has always been the case.


#9

Just read your latest post in this string;
I then went ahead and tried again, and, lo and behold, it worked right away. Beats me as to how come…
The only thing that was different is that I’d put all of the other native Sandbox tools into the toolbar as well.
Just thought you’d like to know, and thanks for following up with your question to everyone. I guess you’re even more perplexed than I am…
Again, this is a really handy work-around.


#10

Thank you for letting us know.
Yes, I’m surprised that splitting the icon off of the others on the toolbar makes any difference.
I’ll try that with the Windiows version.
Happy to hear that things now work as expected.

I’ve often wondered if making a similar ‘layer’ icon in Ruby would be possible to get the same advantage to assign it to a shortcut key. For a layer name of choice. To keep geo-locating the model available if needed.
Maybe its worth a feature request.


#11

Just as a reminder; The first time this worked for me, the Toggle Terrain icon was the only one of the Sandbox tools in the toolbar. Maybe one has nothing to do with the other.


#12

I’m getting nowhere with my Styles apprenticeship;
The tutorials are mostly extolling the virtues of the available, pre-built styles, while skimming over the style-building and management aspects. I’m only looking to build a simple, custom style, and to have access to it whenever I open an SU file, new or not. The Styles management window befuddles me.
Any pointers?


#13

What kind of style settings do you want to make?

Would it help to look at Style Builder and the Styles window together?


#14

Right after I wrote and sent this, I found what I think will give me the info I’m looking for, in the SU Knowledge Base.
I’d been barking up the wrong tree by looking for video tutorials.
As I stated, all I want for now is a handily available (from any SU file) custom style with brightly coloured, and, if necessary, suitably wide edges, lines and/or curves, for tracing along shapes that are in items I can’t see through.
But I think I’m now on the right track. I’ll get back to you, should this not “pan out”…
Thanx for the swift reply and your kind consideration.


#15

OK.

While you can make a style with thick brightly colored edges, I’ve never found it to be worthwhile. It’s just as fast to temporarily edit the template style and then go back to the original when finished with the tracing. I sometimes find I need to use a different color for the edges depending on the image I’ve imported. Sometimes a bright green is easier to see than red. Sometimes an orange works better. It’s fast enough to figure out on the fly.


#16

Thought you’d like to know…
Turns out, when you create 2 grouped objects, and assign one to Location Terrain and the other to Location Snapshot, toggling the toolbar icon lets you alternate viewing one or the other. It works the same way with the keyboard shortcut.
It’s been my experience that initiating the desired function seems to be more sure-fire when creating the layers right after opening a new file, as opposed to after inputs have been saved to it.
I think the only way to go back to seeing both layers simultaneously is by re-assigning one of the groups…


#17

Or turn on both layers in the Layers window.


#18

Correct. This is according to my first post (also see screenshot: Location Snapshot is optional to …)
Functionality of icon and an assigned shortcut key are exactly the same.

Having only the icon ‘Toggle Terrain’ on a separate toolbar appears to make no difference at all in the Windows version of SketchUp. Probably also not in the Mac version.

You can create (or at least should be able to) create one or both mentioned layers at any time during modeling. You can even change their names at any time during modeling, like any other layer you use, (my experience over the years). You can even leave ‘Location Terrain’ empty just to have the ‘Location Snapshot’ optional layer available for toggling. At risk of purging Location Terrain though, since it is not assigned to anything.

No. Just as @DaveR says, turn on both layers through the ‘Layer’ window. Just as you would do with any other layer.

The reason I called them two special layers is that they are tight to this handy icon and thus making it possible to get that shortcut key. Other than that they can be used as just ordinary layers. (at least in the Windows version and for as long as I can remember (SU5 till SU2017).


#19

My bad…
"I think the only way to go back to seeing both layers simultaneously is by re-assigning one of the groups…"
Should have read:
“I think the only way to go back to seeing both layers simultaneously, from the keyboard, is by re-assigning one of the groups”…Toggling through the layers window entails using the mouse, which is what we’re trying to minimize here.
But I get your point(s), and as ever appreciate your making it (them).
As far as the laxity with which the required layers can be created and renamed, my admittedly limited experience has been a lot quirkier than yours. Maybe it’s a SU/OS versions “thing”…
I’ve solved my initial tracing problem using styles, but I’m really glad to know about all this as I’m sure it’ll come in handy every once in a while.


#20

Note that working on a Mac you have the advantage of adding (also changing and deleting ? ) layers through ‘Entity Info’ over the Windows version. something small, but I can’t.
‘Entity Info’ is open much more often than the ‘Layers’ window.