TINY BUG: Shortcut for Show/Hide tray not working at startup

bug

#1

This is a really tiny bug, but a little annoying since I use shortcuts a lot and frequently want to Show/Hide the tray on the working area. I have put it on the plain “N”-key to place it as close as possible to the space-key (which is my most used shortcut btw, recommended for everybody for “Select”=ending most functions). I have a fast PC with system on SSD-disk, so I start/stop SketchUp frequently on a second, getting back the bug every time.
The bug: Directly after SketchUp startup this shortcut is not responding. To “initiate” it, I need to Hide/Show tray using the menus once first. Then this shortcut will respond. Other shortcuts don’t seem to have this bug (tested the shipped “E”-shortcut för “Eraser”,works OK).
Suggestion for solving: I guess the program source code might need to initiate a variable here.
Level of urgent: Not at all (maybe in some future vers. update)
My installation: SketchUp Pro 2017, latest vers.


#2

Just checking, when installing SU did you r-click on installer > Run as administrator?

I’ve set a custom keyboard visibility toggle for a floating tray too. It works as designed on my system.


#3

Thanks för ur quick answer :slight_smile:
I’m ashamed to admit - don’t remember. I must be more careful next install. Right now I don’t dare to re-install because I have deadline to meet. Just curious - could it be a PC/MAC diff (or do u have PC like me?)


#4

We would recommend re-running the installer via right-click
"Run as administrator", and choose the “Repair” option.


#5

Thanks Dan for ur kind tips!
I just followed ur advice very carefully (re-installed on top of old,in repair-mode,as admin) but the “mini-bug” remains. This is not a big issue for us to spend time on, but it makes me curious of how it’s OK in some PCs and not in mine. I have SU Pro 2017 vers 17.1.174 64-bit (hopefully the latest vers). Could it possibly be a version specific issue?


#6

I think not…

For the avoidance of doubt…
Just being the admin or having admin-powers is insufficient.
Close SketchUp 2017.
Select the SketchUp 2017 installer’s exe file, right-click > context-menu > "Run as administrator"
When prompted, choose “Repair”.

If that doesn’t fix things, then you might need to be more adventurous…

Repeat the above steps [==‘Run as administrator’], but when prompted instead of choosing to “Repair” choose to “Uninstall”.
Then immediately repeat the steps [==‘Run as administrator’], then choose to “Install”.

Did that help ?


#7

I have a PC too. Don’t know why there’s a difference with different systems on this issue - yet. It could be a “focus” issue, mouse setting/driver.

SU makes some changes to the registry, like saving program settings. The OS wants to be sure a responsible human is allowing changes to the registry, so that’s why you need to do Run as administrator when installing SU. We just want to be sure there wasn’t an installation issue here.


#8

As an old software (and CAD!) system architect and developer/programmer (back in the good old DOS-days), my intuition hints it might just be an early initialization of some variable that is missing, but as you guys say, it might also be an installation error. But before I uninstall+install I would ask you to do a small test.

It shows up that this tiny bug was wider than I thought - but also even easier to “work around” in a fraction of a second. This affects not only a shortcut for the floating tray but ALL shortcuts. Immediately after SU startup I had to move the camera position (just zoom up/dn or click on empty space has no effect) or select an entity or click on a main menu item or most tool-icons before any shortcut key will respond.

So it would be very interesting if you would do the following test:

  1. Start SU
  2. Before doing anything else - press the “shipped” shortcut “E” for the Eraser tool.
    Does it respond?
  3. Move cam pos with mouse wheel Orbit (or just click Orbit-ikon)
    Does “E”-key respond after that?

If your answers are 2=No and 3=Yes, maybe a little ruby sequence run at startup could invoke and end some of the “response-triggering” functions - and this “mini-bug” is gone!


#9

Good information ! I have tested on my SketchUp 2017 Nvidia machine (Toshiba Qosmio) and can repeat the bug each and every time SketchUp loads.

Like you say, selecting any other tool causes the shortcuts to begin working.

I also notice that if I start with a script opening the Ruby console, and I simply change the window focus from the main application window, to the console window and back again, the shortcuts begin working.

Next to try if a startup script calling: UI.refresh_inspectors will reset things (as it basically redraws the GUI.)


#10

It is privilege for me to have this dialog with you SU-giants! In comparison with you I am just a SU-rookie and certainly regarding ruby, which Dan’s suggestion to redraw the GUI confirms. So I let you take it from here to see if it is possible to make that script do the job. I am really curious about this.


#11

Further testing reveals that the model viewport does not have focus when SU2017 gets done with it’s startup routine.

Simply clicking in the viewport with the mouse, gives the viewport focus, and makes the shortcuts available.

Perhaps some high-lighting of the viewport border would help the user know when the viewport has focus ?


#12

With my workflow, I usually just click somewhere in the workspace - empty space or some geometry - with the select tool or another tool anyway, so the focus issue was never an issue.

I have the extension RpTools. It’s dialogs are always on top of the SU workspace and to activate those tools to work on some selection, one has to click on the extension’s windows dialog to turn focus on the tool. They use the standard windows theme with different colored title bar when active and inactive. After using this extension for so many years, I was used to focusing as needed.


#13

Well, it is new with 2017. It did not happen with 2016. So this behavior is new and unexpected.


#14

You’re right. I just tried it with SU16.