Tig's 2D Tools

I just tried Tig’s 2D tools for the first time, specifically the 2D Text.
The Text comes in as a block, but it doesn’t show up at all in Entity Info when selected?
As a result, I can’t easily move this text onto a specific Tag/Layer …
It appears to come in on Layer 0, and can’t be moved?
Or, is the Text placed on what ever Layer/Tag is “active” at the time?
Does anyone have an insights/advice?

The extension creates the text as a component and gives it the name ~2DText and appends a number after it which you can see in Outliner.

As with any other component you can give it a tag/layer in Entity Info. If you choose to make another tag/layer active before creating the text, the text components will be receive that tag/layer. In this case the geometry will also be given the active tag/layer. Again, this is exactly the same as creating any other component.

Thank You Dave,
I figured that out eventually … Yes, the text shows up in Outliner, but in order to place the 2D text on a particular Tag, one needs to make that tag active (moving off of the sacrosanct tag 0) BEFORE using the tool. Then, you have to remember to reset back to tag 0.
I was looking for (and hoping for) the more convenient utility of being able to select the 2D text component AFTER creation (as you can with conventional Components), and being able to move it to a designated tag using Entity Info. But, since the 2D text doesn’t register in Entity Info when selected, this isn’t possible! (Please correct me if I’m wrong, am I missing something?)
A different workflow, and a little clunky, but still usable I guess …
Thanks again for your help!

No. That is not correct. Just as with any other component, select it and give it a tag.

Of course this can be done in Entity Info. As with any other component you have to select it to do this but it works just fine. No need for some other utility to do this.

You must be missing something because the text component does show in Entity Info when it is selected.

Since you aren’t seeing this, upload a SketchUp model file that illustrates what you are describing.

1 Like

OK, Thanks Dave,
I appreciate your time correcting me!
I’ll take some time this afternoon to go back and look at my test file again, and try it again …

Hi again Dave,
Thanks for your patience on this … still no show in Entity Info …
I’m using SU 2018, and reading Tig’s notes, it appears it may not be “approved” for 2018.
The listing skips from 2017 to 2019, maybe that’s my problem …
Thanks again!

I doubt that’s the problem. I just opened 2018, created some 2D Text and it works as expected.

I asked before that you share the SketchUp file where you are seeing this problem.

Hi again Dave,
I tried Tig’s 2D Text again with a fresh file (and maybe a fresh head?) this morning, and now it seems to work!?
I don’t know what was going on yesterday with my other file (I tried over and over) … but you were right (as usual!).
Thanks for you helpful response and quick attention!

1 Like