Text with leader won't show on the layer I want. Text only does


#1

2015 Make - I can’t get text with leader to show on any layer other than 0. The entity tool says it’s on the layer I want, but I cannot view it there.


#2

I can’t replicate the problem.

Please give us some idea of your layering schema. That is, what sorts of things are you using layers for? How do you have your layers arranged or organized? Do you have raw geometry on layers other than Layer0?

-Gully


#3

Also, do you have a Group or ComponentInstance that contains the text and is itself on a different, non-visible layer? The visibility of the container will dominate that of the contained.


#4

I’ve copied parts of the model from layer 0 and pasted them on other layers named “door end”, etc. I’m going to dimension those parts on the added layers. I can get just text to be visible on the layers, but anytime I try to attach the text to one of the parts, it won’t show on any layer other than layer 0. All of the parts are components that were created on layer 0. Maybe I should try to explode all of the components that I copied from layer 0 and see if that will let the attached text show up on the new level. I’ll try it now.
Thanks for looking at this!


#5

Exploding the copied components allowed me to attach the text!


#6

Seem to have it solved. The leader text when attached to a component only seems to be visible on the layer that the component was created on. I’ll just create a new component on the layer I want the text on. Thanks for the help!


#7

To me it seems that you only think you have sorted things out and get them to work.
And help was on its way.

You do need to check how layers work in SketchUp. They only serve controling visibility, they don’t separate geometry.
You said you get your problems solved by exploding components. They may be even bigger from now on. For exploding components that have some other layer assigned to them will now have the inside entities (now basic entities) on that other layer, not on Layer0 where they should be.
Read the help info about layers.


#8

From your description, it’s pretty hard to tell exactly what you’re doing.
What I can derive from your posts is that you probably haven’t read this:
Does SketchUp Support Layers? — SketchUp Help

And now the raw geometry that resulted from exploding the components is on a Layer other than the Default Layer 0.
Not good…


#9

thanks - I’ll study up. I was not thinking about layers correctly. Thanks for the help.