This is four years later, why is there still not a way to increase the size?

Oct '15

Trimble is aware of SketchUp’s issues on high-dpi displays (which have of late started cropping up on Windows too) but as of SU 2015 there is no fix. By policy they will not comment on possible changes in future updates, so for the near term your only solutions are to work at “best for retina” scaled resolution or live with the eyestrain. This will affect the menus, toolbars, etc. but not the drawing view.

Doesn’t Windows have an option for setting scaling ona per program basis? I’m still on a low DPI display so I haven’t tried. I would expect to find it in Properties for the program file or its shortcut though.

On Win 10, it is actually per display (monitor) setting.

You right-click the Desktop, choose Display Settings, then click one of the big monitor icons (with the numbers in them. (All the settings below change to display the settings for the selected display.)

Then scroll down to Scale and layout and use the drop down picklist to choose from 4 standard scales.

Beneath this picklist there is a link to Advanced scaling settings that allows entering a custom scale (but this is not recommended by Microsoft.)

1 Like