Sketchup and high resolution screens


I use a laptop with very high resolution (3840x2160) and PPI (282).
In Windows i can scale my icons and letters to 175% so everything is readable and clear.

I can start Sketchup Make 2015, but the icons are very small.
Even if i lower the resolution to 1980x1020 it still is very small.

Is there anyway you can change this ?


SketchUp has known issues with high-dpi displays. As these have become more common in the Windows arena (they’ve been on Mac Retina for some years) the pressure is increasing on Trimble to address it, but as of 2015 there isn’t much you can do beyond setting use large buttons in your options.

1 Like