Things disappear when I move camera

Has anyone experienced the following:

Things magically go away when i move the camera


Set the camera to Perpspective and hit Zoom Extents. What happens?

Upload the SKP file.

1 Like

This could be due to the scale of your model which is too small.

1 Like

Here is the file. When i do ctrl+shift+e, camera is always in perspective, its the same thing. I am in mm, so i bet it to small. my part is 74mm. i did scale by 1000 to do any solid manipulations using solid tools and it worked just fine, just when im back down to the 3 inch area, that it clips

hubs.skp (696.3 KB)

actually its 150mm which is about 6 inches or so. I still dont see why SU should have an issue with that size of a part.

So you made the group at a larger scale and then scaled it down without opening the group for editing. Do the following steps exactly and see if that takes care of the problem.

Right click on the group and choose Reset Scale.
Zoom Extents to see the model again.
Open the group for editing and scale the geometry down. You could use the Tape Measure tool to measure across the disk and enter the desired diameter.
Close the group to exit the edit mode.
Zoom Extents as needed to see the model again.

Do you still see the clipping?

As a note: if you had used a component instead of a group, you could just right click on it and choose Scale Definition and save yourself a few steps.

1 Like

I created all the parts, then made a group, scaled the group up by 1000, made my union of the numbers and disk, then deleted the larger group.

even before all the solid tools, the gif i recorded was done before any edits were done created. here is what i did:

Made a 150mm diameter disk, used the follow me tool to create a domed top, created the 3d text.

that was it. the clipping started right after the follow me function.

I followed your steps, and things worked out. The only problem left is if i start over from the beginning, it does the same thing. it seems to be the follow me tool causing the issue.

Why did you delete the larger group.

If you were using the Solid Tools, a new group would be created from the result and it would be at the larger scale.

I don’t think it’s the Follow Me tool doing it. It’s your use of groups and the Solid Tools. This isn’t a problem with components and using Eneroth Solid tools or BoolTools2 and the “Dave Method”.

It seems like you are doing things in a more difficult fashion than you need to or than we’ve talked about before.

It’s not the little part.
It’s the gigantic hidden part surrounding it.

Unhide everything and delete what you don’t need.


The hidden geometry that Geo points out seems out of character for what I thought I knew about your modeling workflow so I never bothered looking for it. It would be a problem though.

1 Like

Ok, i started completely over. Still does it. Here is the gif. No solid tools have been done at all. just made a 150mm disk, made a copy of it, scaled the copy, made a single edit using the follow me tool. Now, i do have the 3 meter copy hidden. are you saying that the 3 meter copy is whats causing the issue?

Yes. That’s what we’re saying.

1 Like

ohhh, ok, let me delete the 1 hidden object. I have never had that happen. Even on the steam engine project, i had hidden cutting tools, and other parts as well. why does it interfere if its hidden?

“The hidden geometry that Geo points out seems out of character for what I thought I knew about your modeling workflow so I never bothered looking for it. It would be a problem though.”

I always delete the bigger component. just leaving the smaller one that is completed. I was in a hurry today to get these hubs printed for the 41 chevy. Also just noticed that my toolbar has the regular solid tools and not eneroth, which accounts for some of the extra junk.

lesson learned. hidden geometry still interferes with visible geometry.

BIG THANKS GUYS:) Never had this happen to me. Thanks again for the help. I learn something new everyday with this program