The plane equation for cface is not valid


#1

Glyndale MESS.skp (142.0 KB)
I got the message when saving the model after 5 hours and this is what it did. I tried an undo, and it just comes back.

What in the world happened? How do i Prevent it, and how do i fix ti?


#2

How you got the distortion I don’t know, it looks like a small version of a bug that still hasn’t been tracked down yet.
One of your main issues is incorrect use of layers.
All raw geometry must remain on layer 0 and only groups and components assigned a layer tag for visibility.
You has edges and faces on different layers which leads to madness and could be responsible for the distortion of your model.
I have removed the layers in your model and put everything back on layer 0 and moved the distorted section to the side. This may help you rebuild the bad section.
Glyndale MESSBox.skp (134.4 KB)

You can read up on Layers Here.


#3

Yikes…
Many Thanks. you can tell this is my first project…

I was following the guy on sketchup essentials I thought.
I wanted to be able to hide the separate parts. Inside walls, outside walls, Roof.
I’m not sure what you mean about raw geometry must remain on layer 0 even after looking over you link.


#4

In it’s most basic form
A rectangle is made up of 5 entities. 1 face and 4 edges. These are raw geometry and should always be drawn and left on layer 0.
If you want to put this rectangle on a different layer, so you can turn it on and off, you must wrap it up in a group or component. This can then be assigned to any layer, but the geometry inside the group/component will remain on Layer 0.
Layers do not separate geometry, only groups and components do. Layers are only used for visibility. Turning on and off things you want to see.


#5

I think I get it most of it.
I can draw the inside walls, outside walls, or whatever on layer zero and then select it all and create a group. Then create a layer and put the group in the layer. BAM! That part is easy.
If I open the group to make an edit am i then working back on layer 0.
I hope you know how much i appreciate your help.
Scott


#6

Yeeees, it would make more sense to create the outside walls, group them and put them on a layer, called perhaps, Outside walls. Then do the same with inside walls and so on. And yes, when you open to edit you are working on layer 0.
Don’t change the active layer. The radio button next to the layer, always leave it on Layer 0. One thing to note, if you explode a group, unfortunately the exploded geometry inherits the groups layer, so keep an eye on that.


#7

Indeed, a trap to be wary of!

I suppose the designers’ thinking was “if the group was meant to show/hide based on the setting of its layer, this should still be true of the contents after it is exploded”. I think this design should apply only to nested groups, components, or images, not to edges and faces because edges and faces off layer0 is a well-known source of confusion and downstream modeling errors. Having the edges and faces suddenly appear independent of the group’s original layer will cause fewer issues than having them mysteriously interact with other visible ungrouped ones.


#8

Last question I hope…
I have made a group for the interior walls and porch and put them in layers interior walls and porch. easy. what i would want to do for the roof is to hide the interior walls and porch LAYERS and then select all. BUT wont this grab the interior walls? or are they protected because they are in a group. I now understand that a layer offers no such protection.
I don’t want to turn this into a training session as i know your time is valuable. Please know that I appreciate your help.


#9

Not quite sure what you mean, but if the layer is hidden and the geometry is grouped then select all will only select all that is visible.
So you can group the inner and outer walls, then triple click on the raw roof geometry and it will select all that is connected(if it is loose/raw geometry) and group it and assign that to a layer.


#10

If I understand your question, the answer is that you can only select things that are visible. So if the layers are set non-visible your selection won’t include anything using those layers. This is another reason why edges and faces off layer0 causes problems: they will intersect and break visible edges and faces, but you can’t see or select them if their layer is hidden!


#11

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.