Phantom white face - what is going on?


#1

Hi, I have a file that I have been working on, it’s gone through a few iterations. I received a request to change some of the paving so I was working on that, but there appears to be a section of the ground plane that is white and it resists any attempts at selecting, deleting, etc. Any idea what’s going on? The picture shows that everything is selectable except for the white face. Also, this is in a group that is open for editing, with other groups turned off. So it’s not that the face is a separate component or nestled within this group. If I click on it nothing happens, and if I double click on it the group closes and nothing is highlighted. Any idea what’s going on? Thanks.


#2

Could you post the file? It’s hard to tell from only looking at the screen shot.


#3

Enable Hidden geometry from the View menu.


#4

Dropbox Link: https://www.dropbox.com/s/mb7x3k6o3bsr2ku/WestGatewayUpdate_current.skp?dl=0


#5

You are using layers incorrectly.
Don’t have the time to explain, but read up on layers.


#6

Here’s what it looks like with hidden geometry.


#7

Can you give me a hint? I don’t know where to start. regardless of what layer it’s on shouldn’t i be able to edit it if I click or double click on it?


#8

Those are not faces, they are a hole in your model.

I agree with Box about layers. I only use layers if I cannot help it. 98% of the time I don’t need them.

Anssi


#9

It is clear from the sneaked view of Entity Info that you have been assigning different layers to various faces.
In SketchUp layers do NOT separate geometry.
It is a recipe for madness - assigning layers to some geometry be used for hiding it, if you hide a face and its edges are on different layers then if you delete one of those edges the face is gone when you set its [former] layer visible !

Layers should be assigned to ‘containers’ - groups or component instances.
Then you can control the containers’ visibility using those layers.

All raw geometry [edges and faces] should always be assigned to Layer0.
Layer0 should ALWAYS be left as the current layer.

One word of warning - if you explode a container then its [former] contents are assigned that container’s [former] layer - even raw geometry - which then needs Layer0 reassigning.
There are tools to help with this - see mine, here:
http://sketchucation.com/pluginstore?pln=TIG_LayerWatcher

Questions resetting Current-Layer away from “Layer0”.
Assigns “Layer0” to all added Geometry [Edges and Faces] irrespective of Current-Layer.
If suitable Selection…
Context-Menu 'Explode-To-Layer0’
Context-Menu ‘Selected-Geometry-To-Layer0’.
including option to process nested geometry…


#10

I see what you’re saying. Actually it’s not what I have been doing, it’s what I haven’t been doing. These geometries are from autocad files that are sent to me. So I’m not creating the layers. I clean the layers up somewhat but not as much as I probably should. So that’s where all the layers are coming from.


#11

When you get the CAD import it’ll be inside a component.
Edit it and select all and change layer in Entity Info to Layer0.
***Alternatively, go into the Layer Browser dialog and select the layers you want to revert to Layer0 [click+shift+click for all between clicks, of click+ctrl for a ‘gapped’ selection] and click the (-) button to remove them, when prompted select all affected to Layer0 option and that saves opening individual containers…
Also remember to use Model Info > Statistics > Purge Unused to clear useless clutter, like unused Layers, ex-CAD blocks etc…

***PS: My LayerWatcher toolset lets you select containers and reset their geometry to Layer0 [including within nested containers] while leaving containers’ layers alone, so that with select-all in the model is possibly and even a safer option…


#12

Thanks Tig. I’m still transitioning from AutoCAD to SketchUP - the habit of wanting everything on layers is hard to break. I do use them somewhat to make it easy to turn things on and off, like putting all the vegetation on a layer. But it’s good to know that you can get away with everything being on a single layer and just using components and groups.


#13

You can still use layers to control visibility, but all raw geometry is assigned Layer0 and then grouped or made into components, which then get the layers used to control visibility…
Even in CAD it’s common to put blocks’ geometry on layer 0 and then the blocks’ layers get used to control the geometry’s visibility as an override.
It’s just that in CAD assigning layers to geometry separates those layers when they are on/off, but all geometry in SketchUp is interconnected when it’s in the same context - this means it ‘sticks together’ and also faces need edges, so they need to be kept on the same layer too - Layer0 is the preferred current layer in almost all circumstances - using separate ‘containers’ as the contexts, with their own layers is the way to go…