How to stop lines from being 'broken'?

A while back I created a drawing, which worked perfectly for what I needed. Many moons later, I’ve found I need to use that drawing again, and add some features. I want to turn off certain layers, and draw in some geometry where the geometry of the hidden layers is. But, any lines on my new geometry are ‘broken’ wherever they intersect with a line on the hidden layer, which I cannot have. I have tried turning the original geometry into a group, or into a component, but it seems to make no matter.

So basically, I need to draw some stuff, but not have it affected by the hidden layers geometry. I’m going to assume this is very easy to do, and the reason it’s not working is because of a fundamental mistake on my part, but I can’t seem to figure it out. Can someone please enlighten me? Thanks…

Without seeing the SKP file we can only guess at the problem. From your descripption it sounds like you made a fundamental error in the initial construction of the model by not grouping geometry and placing the geometry on other layers expecting the layers to provide separation which they don’t. The only way to provide separation between geometry entities is to use groups aor components. Layers only control visibility. The simple rules are Layer 0 remains active at all times. All geometry remains on Layer 0. Make groups or components for parts of the model that should be separate. Other layers are created for the groups and components. Assign those layers to the groups and components.

1 Like

SketchUp’s layers are different from those used by 2D drawing and photo-editing apps. They have some idiosyncratic behavior that can be very confusing if you are expecting them to be like in those apps. In particular, if you associate edges and faces with a non-visible layer, those edges and faces won’t show on the display (even with View->Hidden Geometry checked), can’t be selected using the selection tool, and won’t be used by the inference engine. So, they seem to be “gone” until you make that layer visible again. But in fact they are still active as geometry and will interact with new edges and faces you create! That’s why, as @DaveR wrote, we recommend that you always draw all edges and faces with Layer0 active and visible, and leave them there. No surprises that way!

The only way to prevent this interaction is to put the edges and faces into a group or component before you start to add the new stuff and then associate that group (just the group, not its individual contents) with a non-visible layer to get it out of the way. You say you tried that and it didn’t work. Perhaps if you could list the exact steps you followed (omit nothing) when you tried, we could point out an issue with your workflow.

I tried to upload my file, but despite deleting nearly everything, it still says the file is too large… Is there a way I can link to it or something???

Upload it to Drop Box and share the link.

Try this…https://sketchucation.com/pluginstore?pln=ene_edgeBreaking_v1.0.0

Attached is a link to a google drive - hopefully that works (with the majority of the file deleted, for clarity’s sake, file size etc)… Assuming it does, if you look at the layers, there are two at the bottom called ‘East Wall Shape Dimensions’ and ‘East Wall Steel’. I want to turn off ‘East Wall Shape Dimensions’ and turn on ‘East Wall Steel’, and do some drawing right through some of the geometry of ‘East Wall Shape Dimensions’. I drew one line on ‘East Wall Steel’ and you can see it’s all broken up.

You are correct, I didn’t put most things into groups or components as I went, mostly out of ignorance, but also out of sheer expediency, and I was able to get all the info I needed from the drawing as it is. Also, I’ve sort of had this drawing landed in my lap - I didn’t create the whole thing, I just wound up in a position where we need to edit it, and pull numbers out of it, so we can actually get to building.

But, I would assume, that the necessary geometry could be made into groups or components right now, and then I could draw and get my lines to not be broken, but I can’t seem to manage that. Any suggestions?

https://drive.google.com/open?id=1Y4gSMVr7HuGm1a_piYhR8jG9afsXp2dI

So you didn’t leave Layer 0 active. That’s clear from looking at your model. And you didn’t group things. Unfortunately your attempt to work fast then, is burning you now. I can’t tell from your model what you might have deleted and what you still need.

First step would be to select all geometry–all loose stuff and then go into the few groups you did make and move it all to Layer 0. Set Layer 0 as active and then start group geometry as appropriate. Only assign layers to the groups in the model.

Oh, and unfortunately Eric’s extension suggestion isn’t going to help with this.

Added thought. If you don’t mind leaving the sloppy broken model, just group all of the existing stuff after moving all of the geometry to Layer 0. Put it in one big group. Make Layer 0 active and leave it alone. Go ahead and draw in your new stuff. At least the grouped geometry won’t break the new edges.

Dave R - you sir, are awesome. I just went through the whole drawing, and while I’m sure I don’t have it perfect yet, I put everything on layer 0, then went through everything and grouped what wasn’t already in a group, then assigned that group to a layer. Now I’m able to draw and not have geometry from other groups effect each other. Thanks for the help:)

When you say ‘So you didn’t leave Layer 0 active’ - what do you mean? Do you draw everything on Layer 0, then assign it to a different layer later? My old autocad habits have me creating/activating a layer, and drawing everything on that layer, and when I switch to something new, I switch over to the appropriate layer. I attempt to never have to move things from one layer to another - best practice is to remember to activate the proper layer first, and THEN draw. Should I adjust my workflow for sketchup?

Thanks again,

You leave Layer 0 active at all times (radio button to the left of the layer name) and you do all of your modeling with Layer 0 as active. group edges and faces into either groups or components and do that logically. You only assign groups and components to layers other than Layer 0 but the edges and faces inside those groups/components remain on Layer 0 .

It’s past time to drop those habits like a hot potato. Layers in SketchUp aren’t layers in the AutoCAD sense. They are only visibility tags for groups and components. This is actually very freeing because you never need to worry about which layer you are “working” on. You’re always working on Layer 0. When you open a component for editing to add, subtract, or modify the geometry, you’re doing that on Layer 0.

Absolutely! Again, leave Layer 0 as the active layer and only change layer associations for groups and components.

For some disciplines, layers are predefined and the same in every model. You could create the layers ahead of time and then assign the layers to the groups and components as you make them. For my work there are no standard layers possible and so I save creating layers until the model is at least nearly completed. I create layers based on how I need to show the model in different scenes and I’m thinking about this as I do the modeling. Either way, there’s never a need to chase active layers as you are modeling.

I did some prowling around in your model and found that you have a number of loose (i.e. ungrouped) faces that don’t have all their edges associated with the same layer as the face. This is an example of what @DaveR was warning about that can cause a lot of confusion!

1 Like