Odd Geometry shows up when I triple click on part, but disppears when I try to right click it


#1

Hi Sketchup Users. I have a model with each part on a separate layer. For some reason, the blue lines are from two layers that are turned off. When I triple click on my main part, these lines show up. When I try to right click them, so see or reassign the layer I think they belong on, they disappear. This is a recent issue with this model. At one point it was fine, but I’ve done so much to other parts, I hate to have to go to a day’s old version. When I turn on the layer I think these lines are on, a white “solid” of the part shows up. But I still can’t get rid of them on the part I’m trying to edit. Any ideas would be great.


#2

You are using layers incorrectly.
Layers don’t separate geometry, groups and components do.
Only assign groups or components a layer, all raw geometry should remain on Layer 0 and Layer 0 should remain the active layer 99.8% of the time.

Read more here
http://help.sketchup.com/en/article/3000122


#3

hi "Box"
I’ve heard of this layer 0 thing, but, now that I’ve done it all wrong, how do i fix this particular issue? Maybe I got lucky, as not other parts are so affected. Just these two. I don’t have any other layers turned on. Thanks for being up so late tonight, as it’s 12:14 am here ! Ron


#4

Select all geometry and put it on Layer 0. Use the dropdown in Entity Info.


#5

Hi Dave and Box
Thanks for the suggestions. I tried moving things to layer 0, and most parts turn on and off as they did when they were created on their own layer (I now realize this is not the right way), and now that they’re on Layer 0, the individual layers turn them on/off aka visible/invisible, but the two that are “Stuck” together still appear as a series of blue lines of one part when I triple click the other ! Also, now that everything is on layer 0, how to I know which part I’m editing. Sorry, but this is not as intuitive as I expected, and even Sketchup warns that the way they use layers is not how other CAD programs do, so don’t bring old habits over. I don’t have old ones, just a bad set when I started with Sketchup ! Thanks


#6

That’s the sticky nature of SketchUp’s geometry. In order to keep parts separate, you need to make components or groups. Those act as sort of containers to keep edges from sticking to each other.

The best work flow is to draw the geometry for one part and make it a component. Don’t move on to the next part until you’ve made the first part a component. Note that you can make changes to a component later if needed by editing it. Effectively you are opening the container to make the changes.