The installation of HOUSEBUILDER extension to SketchUp


An old problem, but new to me trying to download and install Ruby Library Depot HomeBuilder extension/plug-in to SketchUp 2015 on my Mac OS X . Got past some of the rb/rbz difficulties and have a pop-up which states that the installation was successful, but
can find NO sign of the extension anywhere. The preference extension installation box does not show the plug-in as it now does for an earlier extension that I got from the 'Extension Store. I’m at a loss, and spent all day working on this problem. Beginner on both the Mac and
SketchUp but see all manner of great possibilities … thanks for any assistance .dennis !!!


Did you look in the “Draw” menu?


Did you tick its check box in Preferences>Extensions? That will make it load and the toolbar will show.


If downloaded from Didier’s Library Depot, there is a good chance that it is not SketchupExtension Ruby class compliant (so it will not appear in the Extensions list of the Preferences dialog, anyway.)

Also a good chance that it is not Ruby 2.x compatible.

[Current version links below in DaveR’s post] (The installation of HOUSEBUILDER extension to SketchUp)


Sir, can you tell me where you found the extension to download and explain how you got it to work. I haven’t been able to find it in the Extension Library. Thanks.


Current metric version here:
Current imperial version here:

Both are rbz files which you can download and install via Install Extension… in Preferences>Extensions.


I was able to get the toolbar into SU2013, but not into SU2014


The up to date versions of this tool have a toolbar - in metric and imperial set ups.
If the tool’s Extension is activated, then its toolbar should be available [but it might need activating too] - in all versions of SketchUp, IF you get the latest RBZ version from the link that @DaveR gave above…
For the avoidance of doubt - there are updated RBZ of both the metric and the imperial versions of this tool - their links are available in this explanatory post:
Use the Preferences > Extensions > Install Archive… button to install the RBZ…


I do not have >Install Archive…button.
What am I missing?


Yes, I installed using the “Install Extension” button. In SU 2013, a tool bar appeared across the top after installation. In SU 2014, the tool bar did not show up and is nowhere to be found. It does not impede my usage, just wondered why the difference.


I hate to say it but you guys are making it more difficult than it really is. Part of it comes from apparently ignoring the link’s both TIG and I have provided to the most current versions of the extension.

After correctly installing it with the Install Extension button, scroll down the list of extensions in Preferences>Extensions and tick the box to the left of Housebuilder. This will make the toolbar show.I indicated this in my first post in this thread as a response to Dennis.


You are correct I mispoke :blush:
It is obviously…
Preferences > Extensions > Install Extension…

One might expect that if you have some wit, then if you have a Preferences > Extensions > Install… button that’d be the one to at least try !
This is SketchUp 1.01…

The links I gave above are for the most current and currently compatible versions, for both metric and imperial versions.
Both of which have Toolbars available, if their Extension is active…
You might need to activate the Toolbar !!

You are making this harder than it needs to be…


[quote=“mrrssy13, post:20, topic:13462”]
Then I used the DIDIER BUR Housebuilders Extension and went through the rb / rbz situation to finally install the Extension to SU 2015 preference.
[/quote] BUT you miss the point - the link I posted is to an updated version of the ‘Didier’ version [and the original '/" too] - your post doesn’t even link what you actually installed…

If someone bothers to update a Plugin for you gratis, and you willfully decide not to use it, then it’s your choice, but please don’t confuse newer users, who might actually fail dismally IF they don’t get the latest Plugin-versions for their newer SketchUp-version - i.e. “my links” which are compatible with >= v2014 :expressionless:


You really can’t see the links in my post? I’ve made a screen shot and drawn a red box around them.
Screenshot - 7_30_2015 , 5_59_22 PM

And TIG’s is in a red box in this screen shot.
Screenshot - 7_30_2015 , 6_02_03 PM

I see those links in both posts. They lead to the updated versions of the Housebuilder Extension


You do need to be a member of Sketchucation but it’s free.


… FREE is good, but I’d gladly pay for the NEW version of HOUSEBUILDER. Managed to get the Version: 1.0 by Steve Hurlburt 2005 up and running but the toolbar is fouled-up and I periodically receive an error message re: the Housebuilder Tool part of the folder. Anyway, it’s useable but not
correct and is driving me a little crazy. I’ve been a member for almost a whole week now … dennis


Dennis, I don’t know what else to say or do for you. The current version, which is entirely functional has practically been laid at your feet and you’re still screwing around with and being frustrated by an old non-updated, not entirely functional version. You say you’d gladly pay for the new version but you don’t have to do that. You do need to sign up as a member of Sketchucation but there’s no charge for that. What do you need? Do you need someone to come to your house and install it for you? I’m not trying to be rude but it’s very frustrating when we’ve spent time laying it all out and made it as simple as possible for you to get the right version and you won’t get it. The old saw, “You can lead a horse to water…” comes to mind.


Thanks for all your efforts and the consternation that has been inflicted.
I really appreciate what you have done in the updating of an old, but very
useful extension and making an easier installation available. I’m just not
able to follow instructions and will have my Apple guy help me. I may even
learn something along the way. Thanks Again for your forbearance
… dennis !!!