The file is curently locked by another user... Sketchup 2021 (please help)

my subscription Sketchup 2021 , and sometimes have a problem , if i open a file (big sketchup file) more than 100mb …"file is curently locked by another user…
please how can I solve it?
thankyou

You will always see that message if you try to open a file that is already open in SketchUp. Try choosing No, then look at the currently open documents and see if it open already.

Really!?

I’m sorry typo…100mb i mean :pray:

Does the file reside in a folder that is being synced to the cloud or are you opening it directly from a cloud service through the Internet?
The consensus is that you should save your file locally and sync it to the cloud only when finished.

Yes, I suspect that… because the sync to Google Drive hasn’t finished yet , thx btw

sometimes everything happens when all files are closed, I suspect because of cloud sync, btw thx

Thanks for the update.

I save my files to a local drive and have my files backed up to Google Drive.

I use Google Drive for Desktop which is replacing Google Backup & Sync.

This backups my files to Drive in the background.

The file is currently locked by another user…

used to happen frequently but not so much now.

What I have noticed is that it can happen when, e.g. I have a model open and do a save as. If I then very soon after try to open the newly saved as file I will get the locked by another user error.

If I wait a little longer I can then open the file.

When it happened more frequently I would sometimes resort to killing the backup & sync process.

Having files in a folder that sync automatically can be troublesome. Some people go years without issue but others end up with Unrecognised file format errors due to a clash of autosync and auto save.

Understood.

For sure, I’ve seen the posts people report on their corrupt files so caution is advisable.

I have to say that I must be one of those who go years without issue…

You’re one of the lucky ones. You should be buying lottery tickets. :smiley:

Try closing SketchUp. Turning off computer, turn on computer, open SketchUp. I am sure it is not the right way to do it, but it seems to work.

For anyone else having a similar problem: possible cause can also be sketchup not shutting down properly in a previous session. Check the running processes and see if sketchup is still listed even if you’ve closed it. I encounter this quite a lot.