TEXTURES Exporting SketchUp Models to Substance Painter UV Mapping Wrapping Unwrapping

Okay, wanted to provide some updates:

Okay, so basically when I was importing the .Dae file from SU into SP I was checking the “create texture set per UDIM title” option and then uploading the folder of materials that SU created along w the DAE. file during the export process.

I think that was leading to the index count problem - I’ll explain why in a sec. When I deselect the create texture set per UDIM title the file imports with the texture sets separated by material (at least that’s what it seems like?)!

When I look at the names of the texture sets that were created there’s more than when SketchUp exported into the material folder. There are 43 Texture sets, but only 25 textures get exported from SketchUp. One specific example is the brass doorknob material. There is a texture set labeled Brass-material in the Dae. import, but there’s no texture labeled Brass in the SU texture exports.


Does anyone know why Sketchup wouldn’t be exporting all of the materials/textures? I’ll likely make a separate post to figure this out and link it back here.

With that in mind, I’m just skipping importing the texture files themselves during the .Dae import and am applying the textures manually within substance painter itself.

Of course, this isn’t happening seamlessly… When I first apply my endless brick texture the scale is way off.

When I scale it down it seems to correct itself, but only while it’s loading/computing. While loading it looks like the

When it finishes loading it looks like this:

No amount of adjustments seems to correct the problem. That said, it takes like 5 minutes for every adjustment to load, so it’s hard to tell if I’ve really exhausted all the options.

Just to test the texture in SketchFab (and to see if i could maybe fix the problem in SF directly), I tried uploading the file to SketchFab, but got the following error message.

Somehow my file is 350mb and my current pro account won’t allow me to upload it.

Any idea why this file would be so bulky all fo the sudden?

I tried reducing the pixels from 4096 to 2048 (keep in mind my computer is now running impossibly slow) and the bumps just sort of mesh together like this:

Down to 1024 looks like this:

512:

You get the point.

Can anyone tell what the problem is just by looking at this?

As a remind, the texture itself is supposed to look like this:

Some updates from the Allgorithmic forum where I posted a question related to the most recent problem:

CAGameDeveloper:
"Are you able to provide your Substance Designer file so I can review and port it over to Painter for testing?

I looked at your painter file, but the material itself wont carry over so I cannot see the details on resolution.

Outside of this, I did review your model and I’m not sure what kind of workflow you’re using, but your house has so many object ids, the normals are not facing correctly on many spots, and the geometry looks like this was all built using CAD software. Your UVs also take up so little density in the 0-1 space.

If you did a retopo over this, and cleaned it up, you could organize everything much better and reduce the object count, plus textures. Since you’re barely using any density per map, why have so many texture sets? Out of the 25+ texture sets you’re using, less than 1% in total of the combined space is being used on average, and these are 4k maps. I would honestly suggest correcting your workflow before moving forward.

If you have any questions let me know."

Me: “Absolutely! Here you go! Just FYI I created it following the instructions in this tutorial:” File attached.

CAGameDeveloper:
From what I can see you have a few issues.

  1. Please review my prior post, your density on your UV maps is way too low… Just to make an example, I took your material and applied it to my wall mesh, but made sure the UVs took only a small part of the space in a 4k map, and here is what I get:

Now if I increase the UV size to fill more of the space I get this:

I also believe your material is outputting at 512x512 which may also be an issue. I normally make my materials at a higher res.

  1. Your UV density takes up such a small amount of space for the amount of area you need to cover, so of course the detail is going to be poor:

  1. The res size of your material, in joint with the fact you’re using low amount of your available 0-1 space is why you’re getting horrible visuals.

If I lower the density even more, I get this:

Update:
I’ve been trying a lot of things and gone down a lot of rabbit holes, none of which have really led me anywhere.

In a “i give up” move, I tried opening the substance in substance player and exporting bitmaps as jpegs along Diffuse:


Glossiness:

Height:

Mask:

Normal:

Specular:

I then uploaded the individual “bitmaps” (?) as textures in the corresponding materials menu in SketchFab:

The model is produced is this:



The size of the bricks is all wrong of course and if you look closely there’s repetitions in the overall texture (which defeats the entire purpose of creating the endless texture, right?), but I guess it’s the closest I’ve gotten to what I’m going for so far.