Texture will not apply

I am working on an architectural model. It has roof trusses and a roof surface. The surface does not touch the trusses. The trusses were modeled in the default white texture. When I textured the roof surface like I wanted with a texture it textured the roof trusses as well. I thought I would simply re-texture them with the default texture but it will not apply.
Any thoughts why this would be?

Material all depend on context, where you applied them. Meaning did you paint to raw geometry or the container?
Paint on a face will override paint on a group, so you can paint one face green and paint the group red and the green face will stay even if you change the group to purple and so on.
We would need to see your model to give you a specific answer.

I am attempting to paint the raw geometry. The texture is from Sketchuptexture.

6255 Rolling HIlls_6a.skp (4.4 MB)


It appears I can paint the roof truss component anything other than the default color.

That is what I did. It will paint anything but the default color. Do I need to “unpaint” the group?

I have drilled down to the lowest level inside the component itself. It will not shake the group color.

Dave got there first but I did this so will post it.
You can see that you can get to the trusses if you go deep enough.
This also shows how much you have painted the groups/components rather than the faces.

Comp material

1 Like

I am able to change the component to a different color or material. What I am wondering is how to get it back to the default color. In other words the component can be changed to anything but the default color. I’ve even tried using the eye dropper from something with the default color and applied to the component but that did not work either.

My computer is too slow today.

There is the Plugin I used in my gif, Remove Group/Component Material

1 Like

That worked!
I was able to change the material designation through the Entity Info box like you did. I guess I need to learn a lot more about what the Entity Info box can do. That was a lot better than trying to go Materials box.
I was wondering where that Remove Group pop up came from!
Thank you very much for helping me out with this.

Not sure why you marked mine as the solution, Dave gave you the same answers with more detail.

Thank you for noting that. I must of lost track.
I will correct.