Material editor color change of texture - error

When trying to change the color of a texture (for example: “Roofing Metal Standing Seam Red”) the texture becomes distorted and pixellated. This only seems to be happening on my machine, as others in the office do not have this problem. I suspect it is my graphics card and am hoping there is a solution. It doesn’t seem to make a difference whether I use hardware acceleration or not. It also makes no difference to check “colorize”. I have a Nvidia Quadro K5000 GPU. Any suggestions? See attached image for example. I would have posted before and after but new users can post only one image.

Can you post the actual texture (either the image or the .skm)?


I think he is referring to the SketchUp standard material in the Roofing library. The texture used in it is not very high quality and when you change its colour gamut the JPG artifacts in it seem to come more visible. However, I don’t think Ryan’s problem is with that.

Basically your ultracool expensive professional graphics card should be able to run SketchUp well. I use cheaper and older versions without problems.
First of all, check that you are using the latest (or a recent) version of the Quadro graphics driver from Nvidia.
Then, check in the Nvidia control panel that your graphics settings are right:

  • is your monitor set to true colour (32-bit)? I have had cards defaulting to 16-bit for some obscure reason.
  • are the Anisotopic Filtering and Antialiasing settings in the 3D settings set to Application controlled


Thank you for the quick response! I am using the standard material in the roofing library although this happens with any material texture. I have checked the settings of my Nvidia Card and they check out as listed. I am also up to date on my driver. Your definition of JPG artifacts is right on and typically with any other machine would be subtle and corrected with the colorize option.