Text Problems - Disappears and other

Hey Peeps… I wonder if someone has come across this before and might be able to suggest a fix?
It happens in every file, every time.
When I choose to add text, the font is set as italics, which I would like to change – and when I go to place it… it disappears before I can. Every file, every font, all the time.

Quick vid:

Thanks for any assistance.

Hi,

It’s probably related to the topic which @slbaumgartner discusses here… 3D text disappears

To change the text style default, go to Window/Model Info/Text, where you will find the default settings for Screen text, Leader Text and Leader Lines display.

Also, be aware (at least on Mac) that there can be problems in Layout with SU models imported with text or dimension text size specified in Points rather than as a physical size - it may get much bigger than it should.

If these suggestions don’t fix your problem of disappearing text, upload a model here (use 7th icon above your post edit window ).

And please complete your profile of which SU version you use, graphics card, etc. That will enable people here to help you better.

PS. By the way, your video doesn’t appear to have uploaded - nothing plays and the screen area is blank above the player controls.

Video is linked to a dropbox account.

No link visible, and it won’t play for me, in Chrome on Mac.

Briefly says ‘loading…’ in Safari, then stops, Play button is greyed out, and still won’t play.

Maybe works in Windows, not Mac?

I right clicked on it an choose Open Video in New Window. and that worked for me

I’m using a Mac so it should work… May require a DropBox account, I guess.

code: https://www.dropbox.com/s/itjoyf50j3aghk8/SKP-garbage.mp4?dl=0

1 Like

That worked for me too - but I had no indication at all that I needed to do that. I have a Dropbox account, as it happens, but shouldn’t need one for the video link to work.

Thanks for the tip.

HAven’t time at the moment to study video but I see it starts with entering 3D Text, for which the defaults are set elsewhere than where I described above for Screen and Leader text. In the 3D text input box itself, I guess.

Hey guys… thanks for taking a look and your feedback. However, this is not the fix. Upon file-open, the text issue is moot, it is only after a third or fourth use of the text tool that this is issue becomes apparent, then it it is constant, until I open a new file. The work around is to make those text additions in the new file, copy and paste them into the open file.

My preferences shows I have completed my profile, perhaps there is an “include” in post checkbox?

Apologies - I only clicked on your Avatar, which doesn’t immediately show the detail, and didn’t at first go far enough beyond that to see your hardware and software profile.

Hi,

So it’s really that dependable then??.. From a troubleshooting perspective that is good news.

And it sure sounds like you must have a set of steps you perform which will trigger the issue so reliably.

If so, then I think the goal here should be focused on isolating the specific set of steps you make in order to trigger the issue.

And if this can happen with any new document you happen to create… Then we should be working with those documents directly… There are many more clues one can find by working with the .skp file, compared to watching a video.

If it’s ultimately a BUG, then others will be able to reproduce it as well. and it will get reported. logged, and fixed in some future update.

Watching the video doesn’t clear up the whole story…

There is no telling what’s actually happening with the text. Yeah, It’s disappearing BUT what does that really mean…

Is it just not there AT ALL???, or is it actually just hidden somewhere in SU’s model space? Having the real .skp file would clear this and other possibilities up. And as I mentioned if this is easily reproducible in a new file… then lets just troubleshoot it from the new file. No one needs to be snooping around in your working SU file.



3D Text generates a component of itself automatically… Do you see the text appearing in the Component Window — even if not appearing in model space?

IF so,… Have you tried to drag it into the document from the component window?



Looking at this from the standpoint of an incompatibility problem unique to your own computer…

How long has this problem been around for?.. I’ve got to assume that you used to do this without to many problems (else you might have commented on it earlier).

Sudden occurrences with computing oddities… should always be meet with a bit of scrutinizing concerning newly installed software, and updates that happened around the same time that problem started.

Maybe an earlier of SU doesn’t have this problem? IF you have a little time, and you’re convinced that there are few other avenues to explorer… then back pedaling to an earlier build might do the trick.