Templates File Location Path Invalid


#1

SketchUp Pro 2018 when launched is generating a message that a File Location Path is invalid,
In Preferences > Files, Templates folder is showing in red.

Templates folder is pointing to C:\Users\Administrator\AppData\Roaming\SketchUp\SketchUp 2018\SketchUp\Templates

However, the Administrator profile no longer exists because SketchUp was installed under the Administrator account on a Windows 10 PC in Audit Mode and once sysprepped, the Administrator profile is removed.

We did not have this issue on SketchUp Pro 2017 as any user that launched SketchUp would have their Templates folder directed to their user profile. For some reason it is not doing this on SketchUp Pro 2018.

All other File Locations are OK, only Templates is an issue.

Please assist.


#2

Download the installer file, right click on it and choose ‘Run as Administrator’ . When prompted, choose ‘repair’


#3

Even in the administrator account, you should run the installer via right-click “Run as administrator”.

(1) ALL the folders from:
"C:\Users\Administrator\AppData\Roaming\SketchUp\SketchUp 2018"
… (that are created during SketchUp install or upon first SketchUp run,) need to be copied (or moved) to:
"C:\Users\Default\AppData\Roaming\SketchUp\SketchUp 2018"

(2) IF you had run SketchUp in the Administrator account, and wished to propagate any saved settings, styles, toolbar layouts, window locations, etc., … then the Registry keys and attributes at:
"HKEY_CURRENT_USER\Software\SketchUp\SketchUp 2018\"
… need to be copied to:
"HKEY_USERS\.DEFAULT\Software\SketchUp\SketchUp 2018\"

Then after sysprepping … whenever a new user account is created, the folders, shortcuts, start menu, and registry keys are COPIED from the “Default” user account to the newly created account.


I’d also suggest pre-installing the patch for Windows 10 slow selection, …

… and (if your machines have dedicated GPUs,) see if you can set the machine to use the high performance GPU rather than the integrated Intel graphics so each user doesn’t need to deal with this.


#4

Hi Dan,
In the School District that I work for, we installed SketchUp 2017 in our Windows 10 Pro image. After sysprep and deploying the image, whenever any non-admin runs the software, the box appears with the wrong file paths for all looking for the admin profile.

Capture2

Thanks.
cje_wwp


#5

Remove the "File Locations" key (and hence all the paths that point to "C:/Users/Administrator/...",) from the current user SketchUp registry hive before “sysprepping”.

SketchUp WILL recreate the proper user paths upon first launch of the application, for each user.

Also make sure all the path attributes in the "Recent File List" key are deleted.
(They might point toward files the users may not have access to.)


#6

Thanks for the reply Dan. My issue is we have machines that have been imaged and I am looking for a solution without having to fix the image, sysprep and then re-deploy. Is there something that cam be done in the registry or the default profile to fix this. I have tested by deleting the File Location key in the HKCU/Software/SketchUp and that worked for my user profile but not a non-admin account.

Thanks.


#7

Chris,

Delete the file AppData\Local\SketchUp\SketchUp 2018\SketchUp\PrivatePreferences.json

before sysprep/image capture or delete the file from the Default profile after image deployment.

Nick


#8

He specifically said SketchUp 2017 which does not use the JSON settings files.
(This would only apply to v 2018 and later.)

Then you’d need to either create .reg files that correct the registry entries or write batch script that does it using reg.exe calls.

Example of a reg file …


Windows Registry Editor Version 5.00

[-HKEY_CURRENT_USER\Software\SketchUp\SketchUp 2017\File Locations]
[-HKEY_CURRENT_USER\Software\SketchUp\SketchUp 2017\Recent File List]


#9

Your problem is that SketchUp wants each user login to have its own set of file folders within that user’s AppData, whereas your system image has captured paths leading to the Administrator’s folders - to which other users won’t even have access. And, because the correct paths are different for each user, you can’t freeze them in a system image regardless of who installed SketchUp! So, as @DanRathbun has stated, your only fix is to remove those settings from the Registry after installing SketchUp but before creating your image. SketchUp will detect that they are missing and fix them the first time each user runs SketchUp. Sorry, but that will require fixing the images or running a per-machine registry script and re-imaging.