Tape measure tool won't create a guide line when it should

Sketchup 20.2.172 64-bit

cannot create a guide between two edge ends when I should be able to. I can create guides between other ends of same edges as well as other edges. I have restarted sketchup, deleted and recreated the offending edge, moved the model to another computer, etc.

Do you have a hidden line drawn between those same two points? Delete it.

Include your .skp file for a pre exact diagnosis.

As usual, if you can share your model we will be able to check a) whether we can reproduce your problem, and b) whether it is due to something in the structure of your model or is a bug. From just the youtube video we can’t do this.

This video may clear up some of the confusionTape measure Tool.

Here is link to model: https://drive.google.com/file/d/1iBBmsejJEIfX9aXV_4zMcE-2HFkYtrFe/view?usp=sharing

uploaders under firefox and edge limited out at 16MB. ???

I cannot find a hidden edge between the edge-ends that fail to allow a guide to be created.

Also downloaded sketchup 2021. Same issue exists.

The line tool doesn’t work between those points either.

It reports that the edge is on a hidden layer ‘Topo lines’.

You are using Layers/Tags incorrectly.

ALWAYS draw geometry with the default tag ‘pencil’ left at Untagged (or Layer0 in older versions.)

Only assign tags to groups or components, or to non-geometric objects like Dimensions or Text.

Set the pencil icon in the Tags panel to Untagged, and LEAVE IT THERE! ALL THE TIME (with very few and rare exceptions).

Your model’s Tag window shows you drawing new geometry on Elevations 2.

DON’T.

Before you go much further, turn on hidden geometry and hidden objects (in the View menu). Select each object (group or component) in turn, and open it for editing. Select all (of the geometry inside it) and change the Tag assigned to Untagged. Tag the object, not the geometry inside it.

You have assigned tags to raw geometry. For example, many of the vertical lines visible in your model, and in the video, have a wide range of tags - Elevations 2, Elevations-interpolated, and numerous others. Select all geometry that is on any one tag, and make it into a group or component, then assign the tag to that, and reset the geometry inside it to Untagged. Alternatively, turn off all tags except one, then make a group or component of what is left showing. Then do as before - open the object for editing, select all inside it, then assign the tag Untagged to it all.

Repeat for each tag in turn, until you have no loose geometry in your model, for any longer than it takes to draw it and make it into a group or component.

1 Like

Yes, there is a hidden line in the same spot preventing the formation of a guide, this is normal behavior for the tape measure tool, when used on the two ends of any single line it defaults to measurement and no guide is created. Here is the way to make guides on top a single line.

and yes you need to pause and listen to @john_mcclenahan. Stop changing the active tag, all geometry should be made and remain untagged. Only assign tags to groups and components. Ye be warned, there be dragons there.

It’s not so bad, here is a quick look at the geometry that need re-tagging after moving all geometry to untagged, it’s not everything.

Thank you john_mcclenahan and endlessfix for a very rapid response. I’ll need to take a little time to process your coachings (admonishing?), but this lets me move forward. I’m surely going to have some additional comments. But a couple of questions: did you use any special tools or just native to quickly find what was going on? I turned on view=>hidden geometry and view=>hidden objects to try to see if there was a hidden edge. Using these don’t cause my (bad boy?) hidden edge tagged under topolines1 to show. Are you independent or have a relationship with sketchup/trimble?

I just used the Line tool to try to draw the line, and got the message I reported.

That forced me to look more carefully at the Tags window, where I saw that the default tag was NOT Untagged, and led to my comments about your improper use of tags, applying them to raw geometry (edges and/or faces).

1 Like

We didn’t intend to be admonishing, if we are vehement in our advice, it’s only to stress how important this particular point is. It’s a very common mistake for newer users to assume that Tags (used to be Layers) separate geometry and prevent it from interacting, as “layers” do in other programs. This confusion is in fact one of the reasons the name was changed. Only groups and components have the ability to encapsulate raw geometry and prevent it from interacting with other geometry. So, even when tag visibility is turned off for a piece of raw geometry, it is simply not displayed on the screen, but still exists there in your model, ready to stick to or interact with any new geometry that crosses it’s path. Your posted problem is a great example of the dangers of this work flow, current visible geometry and tools interacting with invisible geometry that is ungrouped and invisible. Thats how I was able to guess the problem in my first response, before seeing the file. This practice can and often does produce bent distorted ruined models for new users, and we see that problem so often we tend to be strong in our advice to avoid it.

You are almost there, but you would also need to turn on visibility for all tags as I did in the video. Showing hidden geometry/objects will not override Tag visibility, so if a tag is not shown, it’s hidden objects will not be shown either. As you are using SketchUp Pro you might look into the extension CleanUp3, it has many useful features including an option to assign all raw geometry to untagged (it still uses the outdated layer0 term, but works just fine).

I am just another SketchUp user and member of this community.